summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2013-08-09 17:10:40 +0200
committerHyacinthe Cartiaux2015-06-09 14:10:19 +0200
commit90242ca1ee6a3bdced84625b5da2494757cc9065 (patch)
tree424060421b587e96aa13f6a0ac75e5be12c971e0
downloadaur-90242ca1ee6a3bdced84625b5da2494757cc9065.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d115408f70d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pytomtom
+ pkgdesc = Manage your TomTom under Linux
+ pkgver = 0.5.1
+ pkgrel = 2
+ url = http://pytomtom.tuxfamily.org/
+ arch = any
+ license = GPL
+ depends = python2
+ depends = pygtk
+ depends = cabextract
+ source = https://pytomtom.googlecode.com/files/pytomtom-0.5.1.tar.gz
+ md5sums = 4cd3a01c2b020578c8894bd556cef339
+
+pkgname = pytomtom
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..689060f0569a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
+# Great Contributor: Bartek Piotrowski <barthalion@gmail.com>
+pkgname=pytomtom
+pkgver=0.5.1
+pkgrel=2
+pkgdesc="Manage your TomTom under Linux"
+arch=('any')
+url="http://pytomtom.tuxfamily.org/"
+license=('GPL')
+depends=('python2' 'pygtk' 'cabextract')
+source=(https://pytomtom.googlecode.com/files/${pkgname}-${pkgver}.tar.gz)
+md5sums=('4cd3a01c2b020578c8894bd556cef339')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ sed -i -e 's/python/python2/' bin/pytomtom
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -Dm 755 bin/pytomtom "${pkgdir}/usr/bin/pytomtom"
+ chmod -R 755 share # I've no idea how to make it better, but it works.
+ cp -dpr --no-preserve=ownership share "${pkgdir}/usr"
+}