summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2015-06-09 00:17:13 +0100
committerEmmanuel Gil Peyrot2015-06-09 00:17:13 +0100
commit1f91d15e8fdf374cebb2e38c3ee2abc1d31ebb4f (patch)
treeb850965a17045dbc09a1662d148b5cab9fc94da1
downloadaur-1f91d15e8fdf374cebb2e38c3ee2abc1d31ebb4f.tar.gz
Hello Gensokyo. _o/
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD36
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..180463e69c87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = pytouhou-hg
+ pkgdesc = Libre reimplementation of the Touhou 6 engine.
+ pkgver = 633
+ pkgrel = 1
+ url = http://pytouhou.linkmauve.fr/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL3
+ makedepends = mercurial
+ makedepends = cython
+ depends = python
+ depends = sdl2
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = sdl2_ttf
+ depends = libepoxy
+ depends = libgl
+ optdepends = gtk3: for a graphical main menu
+ optdepends = th06-demo-pytouhou: the freeware demo of EoSD.
+ provides = pytouhou=633
+ conflicts = pytouhou
+ source = pytouhou::hg+http://hg.linkmauve.fr/touhou
+ md5sums = SKIP
+
+pkgname = pytouhou-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ceb372d77520
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+
+_pkgbase=pytouhou
+pkgname="$_pkgbase-hg"
+pkgver=633
+pkgrel=1
+pkgdesc='Libre reimplementation of the Touhou 6 engine.'
+arch=('i686' 'x86_64' 'armv7h')
+url='http://pytouhou.linkmauve.fr/'
+license=('GPL3')
+depends=('python' 'sdl2' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf' 'libepoxy' 'libgl')
+makedepends=('mercurial' 'cython')
+provides=("pytouhou=$pkgver")
+conflicts=('pytouhou')
+optdepends=('gtk3: for a graphical main menu'
+ 'th06-demo-pytouhou: the freeware demo of EoSD.')
+
+source=("$_pkgbase::hg+http://hg.linkmauve.fr/touhou")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgbase"
+ hg identify -n
+}
+
+build() {
+ cd "$srcdir/$_pkgbase"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgbase"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sts=2 sw=2 et: