summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2024-02-09 11:41:44 +0100
committerMarco Rubin2024-02-09 11:41:44 +0100
commite5aa20b12c0b32424cd802079ae04518a300fc90 (patch)
tree6bbd811da0f5f1ea378c86496ba75626a23cb4c3
parentd802e9fab9fd650c10c0ce5a8b1abac63f667f9f (diff)
downloadaur-e5aa20b12c0b32424cd802079ae04518a300fc90.tar.gz
PEP 517-based building; use github source
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9362880c865..4efac50399ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = pyupgrade
pkgdesc = A tool to automatically upgrade syntax for newer versions of the language
pkgver = 3.15.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/asottile/pyupgrade
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
depends = python-tokenize-rt
- source = https://files.pythonhosted.org/packages/source/p/pyupgrade/pyupgrade-3.15.0.tar.gz
- b2sums = 8a565510066236251c78e8ce62bef749dfcc2b4e4c1ee5b8c977461e4a7d3b6f1e39c1303343af8529ec7a2032d2c7d15e122f98f620a7671cfa47105a137554
+ source = https://github.com/asottile/pyupgrade/archive/v3.15.0.tar.gz
+ b2sums = a13eca9d5591068355722e0cd0d16debce7c4d55fbce2759af9f0154cf5591beca20bc7e4551d6d707ef63deccf142e639229fb052063be68921c435731dd5ef
pkgname = pyupgrade
diff --git a/PKGBUILD b/PKGBUILD
index 59bb7143748f..683be54ac820 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,24 @@
pkgname=pyupgrade
pkgver=3.15.0
-pkgrel=1
+pkgrel=2
pkgdesc="A tool to automatically upgrade syntax for newer versions of the language"
arch=('any')
url="https://github.com/asottile/pyupgrade"
license=('MIT')
-depends=("python" "python-tokenize-rt")
-makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/p/$pkgname/$pkgname-$pkgver.tar.gz")
-b2sums=('8a565510066236251c78e8ce62bef749dfcc2b4e4c1ee5b8c977461e4a7d3b6f1e39c1303343af8529ec7a2032d2c7d15e122f98f620a7671cfa47105a137554')
+depends=(python python-tokenize-rt)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+source=("$url/archive/v$pkgver.tar.gz")
+b2sums=('a13eca9d5591068355722e0cd0d16debce7c4d55fbce2759af9f0154cf5591beca20bc7e4551d6d707ef63deccf142e639229fb052063be68921c435731dd5ef')
build() {
cd $pkgname-$pkgver
- python3 setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $pkgname-$pkgver
- python3 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}