summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2015-06-01 14:20:35 -0400
committerskydrome2015-06-01 14:20:35 -0400
commite4ce43d239cf053b356c35e8a0926438498bb07b (patch)
tree4f4caeb3c3bb4e9727f9996ec66692369693555f
downloadaur-e4ce43d239cf053b356c35e8a0926438498bb07b.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..577512ef67f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pyutil
+ pkgdesc = general-purpose python library (used by tahoe-lafs)
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/pyutil
+ arch = any
+ license = GPL2
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-simplejson
+ depends = zbase32
+ depends = twisted
+ source = http://pypi.python.org/packages/source/p/pyutil/pyutil-2.0.0.tar.gz
+ md5sums = 025a06985691133479500139a3729909
+
+pkgname = pyutil
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5622ba74643
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Nicolas Pouillard <nicolas.pouillard@gmail.com>
+# Contributor: Peter Simons <simons@cryp.to>
+
+pkgname=pyutil
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="general-purpose python library (used by tahoe-lafs)"
+arch=('any')
+url='http://pypi.python.org/pypi/pyutil'
+license=('GPL2')
+depends=('python2' 'python2-simplejson' 'zbase32' 'twisted')
+makedepends=('python2-setuptools')
+source=("http://pypi.python.org/packages/source/p/pyutil/pyutil-$pkgver.tar.gz")
+md5sums=('025a06985691133479500139a3729909')
+
+build(){
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py build
+ #python2 setup.py trial
+}
+
+package(){
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir" --prefix='/usr' --optimize=1
+ rm -r "$pkgdir/usr/pyutil"
+}