summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2017-01-22 14:57:01 +0100
committerBalló György2017-01-22 14:57:01 +0100
commit53aa7177fbbfed833d27d392209fc9171c727d22 (patch)
treec34027cae4d7b1e7d52b7b8fe79a81a00dc9fe23
downloadaur-53aa7177fbbfed833d27d392209fc9171c727d22.tar.gz
Move package from [community]
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ad4acc0a881
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pywebkitgtk
+ pkgdesc = Python bindings to the WebKit GTK+ port
+ pkgver = 1.1.8
+ pkgrel = 3
+ url = http://code.google.com/p/pywebkitgtk/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = webkitgtk2
+ depends = pygtk
+ options = !makeflags
+ source = http://pywebkitgtk.googlecode.com/files/pywebkitgtk-1.1.8.tar.gz
+ md5sums = 158335385354ba38090c9324b37bf225
+
+pkgname = pywebkitgtk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e32f3e9fb60d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 131550 2015-04-17 17:12:22Z bgyorgy $
+# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: kasa <biuta.jr@gmail.com>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=pywebkitgtk
+pkgver=1.1.8
+pkgrel=3
+pkgdesc="Python bindings to the WebKit GTK+ port"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/pywebkitgtk/"
+license=('LGPL')
+depends=('webkitgtk2' 'pygtk')
+options=('!makeflags')
+source=(http://pywebkitgtk.googlecode.com/files/${pkgname}-${pkgver}.tar.gz)
+md5sums=('158335385354ba38090c9324b37bf225')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}