summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCork2015-07-12 13:45:22 +0200
committerCork2015-07-12 13:45:22 +0200
commit74293fe1a9e069a0066cbd105592076ef2bbae57 (patch)
tree6a58fc75f2c70c259e831c35510516b834c9dd69
parentc2d6f6ea396aff7b740002e83338028e662243be (diff)
downloadaur-74293fe1a9e069a0066cbd105592076ef2bbae57.tar.gz
Fix missing icon in application menu
-rw-r--r--PKGBUILD3
-rw-r--r--pywinery.install14
2 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4944a1cb911..890d3f866d0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,6 +8,7 @@ arch=('any')
makedepends=('python2')
depends=('python2' 'python2-gobject' 'xdg-utils' 'icoutils' 'pygtk' 'libglade' 'librsvg' 'wine')
optdepends=('winetricks: Install various redistributable runtime libraries in Wine')
+install='pywinery.install'
source=('pywinery_0.3-2.tar.gz::https://drive.google.com/uc?export=download&id=0B4gfhO4VUgcfb2Z1RkNQT2wyYlU')
sha256sums=('12fb55ee5aa7cb82b68cb1a1f7c03bdde8af1c68d8c680c2dad7b7c806d48fcb')
@@ -21,4 +22,6 @@ build() {
package() {
cd ${srcdir}/${pkgver}
python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 ${pkgdir}/usr/share/pywinery/pywinery.svg ${pkgdir}/usr/share/icons/hicolor/scalable/apps/pywinery.svg
+ rm ${pkgdir}/usr/share/pywinery/pywinery.svg
}
diff --git a/pywinery.install b/pywinery.install
new file mode 100644
index 000000000000..214da2ef9421
--- /dev/null
+++ b/pywinery.install
@@ -0,0 +1,14 @@
+post_install() {
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: