summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis Salmanovich2021-11-16 11:45:25 +0200
committerDenis Salmanovich2021-11-16 11:45:25 +0200
commit9bf70e261bad93ea2c63a95740ce8bbb4b688f51 (patch)
treed32131d008ac50ea369bc887d121a53af3d024ea
downloadaur-9bf70e261bad93ea2c63a95740ce8bbb4b688f51.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
-rw-r--r--pyxenon.desktop10
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..465543fe9ba5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pyxenon
+ pkgdesc = Pyxenon - xenon like game preview written in python
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://games.os.vc
+ arch = x86_64
+ license = GPLv3
+ source = https://games.os.vc/pygames/pyxenon-0.1/pyxenon.tar.gz
+ source = pyxenon.desktop
+ sha256sums = 23b53a662e5d68bd54e0336518b74d5d5d0ddad0cc7d5d2656e77717ac1dad7f
+ sha256sums = 6124c10735be364fa02c5dbcd33d1647e3a65119f7241151d3eba389033b9b21
+
+pkgname = pyxenon
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f641cd0e0e7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: -=De/\/=-
+# Author: -=De/\/=-
+pkgname=pyxenon
+pkgver=0.1
+pkgrel=1
+pkgdesc="Pyxenon - xenon like game preview written in python"
+arch=('x86_64')
+url='https://games.os.vc'
+license=('GPLv3')
+
+source=('https://games.os.vc/pygames/pyxenon-0.1/pyxenon.tar.gz'
+ 'pyxenon.desktop')
+
+package() {
+ cd ${srcdir}
+ install -d -m755 ${pkgdir}/usr/local/games/pyxenon
+ install -d -m755 ${pkgdir}/usr/local/bin
+ install -D -m644 pyxenon.desktop ${pkgdir}/usr/share/applications/pyxenon.desktop
+ install -D -m755 pyxenon ${pkgdir}/usr/local/bin/pyxenon
+ install -D -m755 main.bin ${pkgdir}/usr/local/games/pyxenon/main.bin
+ install -D -m644 game_font.ttf ${pkgdir}/usr/local/games/pyxenon/game_font.ttf
+
+ cp -r images ${pkgdir}/usr/local/games/pyxenon/
+ cp -r sounds ${pkgdir}/usr/local/games/pyxenon/
+
+}
+sha256sums=('23b53a662e5d68bd54e0336518b74d5d5d0ddad0cc7d5d2656e77717ac1dad7f'
+ '6124c10735be364fa02c5dbcd33d1647e3a65119f7241151d3eba389033b9b21')
diff --git a/pyxenon.desktop b/pyxenon.desktop
new file mode 100644
index 000000000000..1cbc2fc93236
--- /dev/null
+++ b/pyxenon.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Exec=/usr/local/bin/pyxenon
+Icon=/usr/local/games/pyxenon/images/pyxenon.ico
+Name=Pyxenon
+Terminal=false
+Type=Application
+Categories=GNOME;GTK;Game;
+Encoding=UTF-8
+Comment=Pyxenon - xenon like game written in python
+