summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:43:40 +0200
committerStefan Husmann2015-06-09 00:43:40 +0200
commit398ba513f706bbf2077c7a621a76d7f2e1ca714e (patch)
tree943a59f6f1911292f4db548144ade5ab92470f15
downloadaur-398ba513f706bbf2077c7a621a76d7f2e1ca714e.tar.gz
initial version
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD36
-rw-r--r--pyxplot.changelog24
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f0b3877f7a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = pyxplot
+ pkgdesc = Command-line graphing package with a simple interface that produces publication-quality output.
+ pkgver = 0.9.2
+ pkgrel = 3
+ url = http://www.pyxplot.org.uk/
+ changelog = pyxplot.changelog
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = libxml2
+ depends = texlive-latexextra
+ depends = imagemagick
+ depends = fftw
+ depends = gsl
+ depends = python2
+ depends = cfitsio
+ depends = ghostscript
+ optdepends = python-scipy: mathematical functions
+ optdepends = python-numpy: mathematical functions
+ optdepends = gsl: fitting
+ optdepends = gv: for the X11 terminal
+ optdepends = ggv: PostScript files
+ provides = pyxplot
+ source = http://www.pyxplot.org.uk/src/pyxplot_0.9.2.tar.gz
+ md5sums = 2aa8445720f94ca23a7cf6688454ce84
+
+pkgname = pyxplot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c213476b8a6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Gergely Imreh <imrehg(at)gmail(dot)com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=pyxplot
+pkgver=0.9.2
+pkgrel=3
+pkgdesc="Command-line graphing package with a simple interface that produces publication-quality output."
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://www.pyxplot.org.uk/"
+changelog=${pkgname}.changelog
+provides=('pyxplot')
+depends=('libxml2' 'texlive-latexextra' 'imagemagick' 'fftw' 'gsl' 'python2' 'cfitsio' 'ghostscript')
+makedepends=()
+optdepends=('python-scipy: mathematical functions'
+ 'python-numpy: mathematical functions'
+ 'gsl: fitting'
+ 'gv: for the X11 terminal'
+ 'ggv: PostScript files')
+source=("http://www.pyxplot.org.uk/src/${pkgname}_${pkgver}.tar.gz")
+md5sums=('2aa8445720f94ca23a7cf6688454ce84')
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ # LDFLAGS to remove harmful -Wl,--as-needed
+ # USRDIR because otherwise it seem to look for help file in wrong directory
+ export LDFLAGS="${LDFLAGS//-Wl,--as-needed} -lpthread"
+ sed -i s+python+python2+ Makefile
+ sed -i s+-ltermcap++ Makefile
+ make USRDIR="/usr"
+}
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ install -d ${pkgdir}/usr
+ make USRDIR="${pkgdir}/usr" MANDIR="${pkgdir}/usr/share/man/man1" install
+}
diff --git a/pyxplot.changelog b/pyxplot.changelog
new file mode 100644
index 000000000000..845fe48cde01
--- /dev/null
+++ b/pyxplot.changelog
@@ -0,0 +1,24 @@
+2011-01-13 Gergely Imreh <imrehg@gmail.com>
+
+ * 0.8.4-1 :
+ upstream minor bugfix release.
+ The code has been cleaned up to allow safe compilation with -O2
+ optimisation, which yields a modest speed improvement.
+
+2010-11-05 Gergely Imreh <imrehg@gmail.com>
+
+ * 0.8.3-1 :
+ new upstream release.
+ removed docs from package
+
+2010-08-28 Gergely Imreh <imrehg@gmail.com>
+
+ * 0.8.2-1:
+ new upstream release
+ disabling kpathsea and termcap library calls, as they seem to be
+ broken on Arch.
+
+2010-03-02 Gergely Imreh <imrehg@gmail.com>
+
+ * 0.7.1-1:
+ new upstream release