summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2022-02-02 20:37:26 +0100
committerhaawda2022-02-02 20:37:26 +0100
commit69b3df0b439e6e796736d6e4c3fbdd8b4f8bfe40 (patch)
treec14082df7de3a1fbc836b7c710d3b4150c765ec7
parentedbf11a9eb3159b072f45face9229ae3390f749f (diff)
downloadaur-69b3df0b439e6e796736d6e4c3fbdd8b4f8bfe40.tar.gz
fix dependencies and makedependencies
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 560a402772ba..da9bc0f9fc9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,27 @@
pkgbase = pyxplot
pkgdesc = Command-line graphing package with a simple interface that produces publication-quality output.
pkgver = 0.9.2
- pkgrel = 4
+ pkgrel = 5
url = http://www.pyxplot.org.uk/
changelog = pyxplot.changelog
arch = i686
arch = x86_64
license = GPL2
+ makedepends = imagemagick
+ makedepends = ghostscript
+ makedepends = wget
+ makedepends = python2
depends = libxml2
depends = texlive-latexextra
- depends = imagemagick
depends = fftw
depends = gsl
- depends = python2
- depends = cfitsio
- depends = ghostscript
optdepends = python-scipy: mathematical functions
optdepends = python-numpy: mathematical functions
optdepends = gsl: fitting
optdepends = gv: viewing PostScript files
+ optdepends = ghostscript: for postscript
provides = pyxplot
source = http://www.pyxplot.org.uk/src/pyxplot_0.9.2.tar.gz
- sha256sums = 1c592a0bc77caec445a8d72534471c01d66ca1806309e6c983847c2e0b95e689
+ sha256sums = 041074956c99d16125cf455dd57ad6908814e4abe4bfbff6125c3b10e63e5f29
pkgname = pyxplot
-
diff --git a/PKGBUILD b/PKGBUILD
index a21435f30e23..ed31699de676 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,22 @@
pkgname=pyxplot
pkgver=0.9.2
-pkgrel=4
+pkgrel=5
pkgdesc="Command-line graphing package with a simple interface that produces publication-quality output."
arch=('i686' 'x86_64')
license=('GPL2')
url="http://www.pyxplot.org.uk/"
changelog=${pkgname}.changelog
provides=('pyxplot')
-depends=('libxml2' 'texlive-latexextra' 'imagemagick' 'fftw' 'gsl' 'python2' 'cfitsio' 'ghostscript')
-makedepends=()
+depends=('libxml2' 'texlive-latexextra' 'fftw' 'gsl')
optdepends=('python-scipy: mathematical functions'
'python-numpy: mathematical functions'
'gsl: fitting'
- 'gv: viewing PostScript files')
+ 'gv: viewing PostScript files'
+ 'ghostscript: for postscript')
+makedepends=('imagemagick' 'ghostscript' 'wget' 'python2')
source=("http://www.pyxplot.org.uk/src/${pkgname}_${pkgver}.tar.gz")
-sha256sums=('1c592a0bc77caec445a8d72534471c01d66ca1806309e6c983847c2e0b95e689')
+sha256sums=('041074956c99d16125cf455dd57ad6908814e4abe4bfbff6125c3b10e63e5f29')
build() {
cd ${pkgname}-${pkgver}