summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2021-03-13 11:53:13 +0100
committerhaawda2021-03-13 11:53:13 +0100
commitedbf11a9eb3159b072f45face9229ae3390f749f (patch)
treec67f9b6689bc105d4c9571e6b625b8966ac0a8de
parent398ba513f706bbf2077c7a621a76d7f2e1ca714e (diff)
downloadaur-edbf11a9eb3159b072f45face9229ae3390f749f.tar.gz
minor changes
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f0b3877f7a4..560a402772ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pyxplot
pkgdesc = Command-line graphing package with a simple interface that produces publication-quality output.
pkgver = 0.9.2
- pkgrel = 3
+ pkgrel = 4
url = http://www.pyxplot.org.uk/
changelog = pyxplot.changelog
arch = i686
@@ -18,11 +18,10 @@ pkgbase = pyxplot
optdepends = python-scipy: mathematical functions
optdepends = python-numpy: mathematical functions
optdepends = gsl: fitting
- optdepends = gv: for the X11 terminal
- optdepends = ggv: PostScript files
+ optdepends = gv: viewing PostScript files
provides = pyxplot
source = http://www.pyxplot.org.uk/src/pyxplot_0.9.2.tar.gz
- md5sums = 2aa8445720f94ca23a7cf6688454ce84
+ sha256sums = 1c592a0bc77caec445a8d72534471c01d66ca1806309e6c983847c2e0b95e689
pkgname = pyxplot
diff --git a/PKGBUILD b/PKGBUILD
index c213476b8a6d..a21435f30e23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=pyxplot
pkgver=0.9.2
-pkgrel=3
+pkgrel=4
pkgdesc="Command-line graphing package with a simple interface that produces publication-quality output."
arch=('i686' 'x86_64')
license=('GPL2')
@@ -15,12 +15,12 @@ makedepends=()
optdepends=('python-scipy: mathematical functions'
'python-numpy: mathematical functions'
'gsl: fitting'
- 'gv: for the X11 terminal'
- 'ggv: PostScript files')
+ 'gv: viewing PostScript files')
source=("http://www.pyxplot.org.uk/src/${pkgname}_${pkgver}.tar.gz")
-md5sums=('2aa8445720f94ca23a7cf6688454ce84')
+sha256sums=('1c592a0bc77caec445a8d72534471c01d66ca1806309e6c983847c2e0b95e689')
+
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
./configure --prefix=/usr
# LDFLAGS to remove harmful -Wl,--as-needed
# USRDIR because otherwise it seem to look for help file in wrong directory
@@ -29,8 +29,9 @@ build() {
sed -i s+-ltermcap++ Makefile
make USRDIR="/usr"
}
+
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- install -d ${pkgdir}/usr
- make USRDIR="${pkgdir}/usr" MANDIR="${pkgdir}/usr/share/man/man1" install
+ cd ${pkgname}-${pkgver}
+ install -d "$pkgdir"/usr
+ make USRDIR="$pkgdir"/usr MANDIR="$pkgdir"/usr/share/man/man1 install
}