summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Zenker2017-05-22 19:20:54 +0200
committerErik Zenker2017-05-22 19:20:54 +0200
commitbcc7764cffe2812c26168e6133161078fc4217c2 (patch)
treea3feeb8f003753b9de7338ffa5788628d6d208ba
downloadaur-bcc7764cffe2812c26168e6133161078fc4217c2.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD44
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2986bb159213
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = q-git
+ pkgdesc = A platform-independent promise library for C++, implementing asynchronous continuations
+ pkgver = r405.ad0d31b
+ pkgrel = 1
+ url = https://github.com/google/benchmark}
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = cmake
+ depends = gcc-libs
+ source = q-git::git+https://github.com/grantila/q.git
+ sha256sums = SKIP
+
+pkgname = q-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc5f7df8d996
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Erik Zenker <erikzenker at posteo dot de>
+pkgname=q-git
+pkgver=r405.ad0d31b
+pkgrel=1
+pkgdesc="A platform-independent promise library for C++, implementing asynchronous continuations"
+arch=('i686' 'x86_64')
+url="https://github.com/google/benchmark}"
+license=('Apache')
+depends=(gcc-libs)
+makedepends=('cmake')
+
+source=("${pkgname}::git+https://github.com/grantila/q.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+
+ mkdir -p build && cd build
+
+ cmake .. -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=ON \
+ -Dq_BUILD_TESTS=OFF
+}
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}/build"
+ make -j
+}
+
+check() {
+ cd "${srcdir}/${pkgname}/build"
+ ctest
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/build"
+ make DESTDIR="$pkgdir/" install
+}