summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorswordfeng2024-01-26 07:54:16 +0000
committerswordfeng2024-01-26 08:01:28 +0000
commitc3e5fb0a1627c1ce5d97feb026d1293443ab1c72 (patch)
treec465c383dcff2de789259484626e3353390b33a8
parentd73a6b4c07d7f86cc3bc4acd6f27e8c4f199ed84 (diff)
downloadaur-qaac-wine.tar.gz
upgrade to 2.81, update wrapper and add simple check
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rwxr-xr-xwrapper.sh4
3 files changed, 20 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac346ed95fd3..e2efc1083b68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qaac-wine
pkgdesc = QuickTime AAC/ALAC encoder (wine version)
- pkgver = 2.80
+ pkgver = 2.81
pkgrel = 1
url = https://github.com/nu774/qaac
arch = x86_64
@@ -10,15 +10,15 @@ pkgbase = qaac-wine
makedepends = winetricks
makedepends = binutils
depends = wine
- source = https://github.com/nu774/qaac/releases/download/v2.80/qaac_2.80.zip
+ source = https://github.com/nu774/qaac/releases/download/2.81/qaac_2.81.zip
source = iTunes64Setup.exe::https://www.apple.com/itunes/download/win64
source = https://raw.githubusercontent.com/nu774/qaac/master/COPYING
source = https://www.apple.com/legal/sla/docs/iTunesWindows.pdf
source = wrapper.sh
- sha256sums = 1a746d7d68fe8429c99ee172ac4e8640d11e80909be47567ae24b6ad99bddae9
+ sha256sums = 94de510c8b8dd47f752d53a976bd3ba8691fd6f821075e6fa170ce1f1bc8dc5e
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = b56ba8ca4a9f0fef6e0c636a4ee26a9c6a17f1e7ba301aef56fc7ddc0854be42
+ sha256sums = 6591c998319680a4474ee93ffc3a50c9be143e53f2e636d8fe66538cde6aa1e3
pkgname = qaac-wine
diff --git a/PKGBUILD b/PKGBUILD
index adcc912ac42a..96dfec509172 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=qaac-wine
_pkgname=qaac
-pkgver=2.80
+pkgver=2.81
pkgrel=1
pkgdesc="QuickTime AAC/ALAC encoder (wine version)"
arch=('x86_64')
@@ -15,16 +15,16 @@ url="https://github.com/nu774/qaac"
license=('custom')
depends=('wine')
makedepends=('p7zip' 'wine' 'winetricks' 'binutils')
-source=("https://github.com/nu774/qaac/releases/download/v${pkgver}/qaac_${pkgver}.zip"
+source=("https://github.com/nu774/qaac/releases/download/${pkgver}/qaac_${pkgver}.zip"
"iTunes64Setup.exe::https://www.apple.com/itunes/download/win64"
"https://raw.githubusercontent.com/nu774/qaac/master/COPYING"
"https://www.apple.com/legal/sla/docs/iTunesWindows.pdf"
"wrapper.sh")
-sha256sums=('1a746d7d68fe8429c99ee172ac4e8640d11e80909be47567ae24b6ad99bddae9'
+sha256sums=('94de510c8b8dd47f752d53a976bd3ba8691fd6f821075e6fa170ce1f1bc8dc5e'
'SKIP'
'SKIP'
'SKIP'
- 'b56ba8ca4a9f0fef6e0c636a4ee26a9c6a17f1e7ba301aef56fc7ddc0854be42')
+ '6591c998319680a4474ee93ffc3a50c9be143e53f2e636d8fe66538cde6aa1e3')
extract_filename() {
if [ "$(head -c 2 "$1" | tr -d '\0')" == "MZ" ]; then
@@ -51,6 +51,15 @@ build() {
done
}
+check() {
+ export WINEDEBUG=-all
+ export WINEPATH="${srcdir}"
+ export WINEPREFIX="${srcdir}/wineprefix"
+
+ wine "${srcdir}/qaac_${pkgver}/x64/qaac64.exe" --check && \
+ wine "${srcdir}/qaac_${pkgver}/x64/refalac64.exe" --check
+}
+
package() {
mkdir -p "${pkgdir}/usr/lib/qaac"
diff --git a/wrapper.sh b/wrapper.sh
index 3d9580aac517..21c659791cfb 100755
--- a/wrapper.sh
+++ b/wrapper.sh
@@ -1,3 +1,5 @@
#!/bin/sh
+# disable wine error messages by default
+export WINEDEBUG="${WINEDEBUG:=-all}"
program=`basename "$0"`
-/usr/bin/wine "/usr/lib/qaac/${program}64.exe" "$@"
+exec /usr/bin/wine "/usr/lib/qaac/${program}64.exe" "$@"