summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2018-11-27 14:32:30 +0100
committerJosip Ponjavic2018-11-27 14:32:30 +0100
commit15d095fe9988d293f86898e798180eb45e908e3e (patch)
treea6498685cb640f0e7640ba56640c1ced15b561f4
parent8b83346a9c80e00673ea1837739b8806b221e03e (diff)
downloadaur-15d095fe9988d293f86898e798180eb45e908e3e.tar.gz
update for cmake switch
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f435ced2287f..aebbad81494a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = qactus-git
pkgdesc = A Qt-based OBS notifier application
- pkgver = 0.9.9.r330.g4c12cf7
+ pkgver = 1.0.0.r4.g333bcf8
pkgrel = 1
url = https://github.com/javierllorente/qactus
arch = x86_64
license = GPL2
license = GPL3
+ makedepends = cmake
makedepends = git
depends = desktop-file-utils
depends = gtk-update-icon-cache
@@ -13,7 +14,7 @@ pkgbase = qactus-git
provides = qactus
provides = libqobs.so
conflicts = qactus
- source = git+https://github.com/javierllorente/qactus.git
+ source = qactus::git+https://github.com/javierllorente/qactus.git
md5sums = SKIP
pkgname = qactus-git
diff --git a/PKGBUILD b/PKGBUILD
index cf7e93a2fdd4..4fdb3ef41939 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,33 @@
# Contributor:
pkgname=qactus-git
-pkgver=0.9.9.r330.g4c12cf7
+pkgver=1.0.0.r4.g333bcf8
pkgrel=1
pkgdesc='A Qt-based OBS notifier application'
arch=(x86_64)
url='https://github.com/javierllorente/qactus'
license=(GPL2 GPL3)
depends=(desktop-file-utils gtk-update-icon-cache qtkeychain)
-makedepends=(git)
+makedepends=(cmake git)
conflicts=(qactus)
provides=(qactus libqobs.so)
-source=(git+https://github.com/javierllorente/qactus.git)
+source=("${pkgname%-*}::git+https://github.com/javierllorente/qactus.git")
md5sums=(SKIP)
pkgver() {
cd qactus
- version=$(grep 'VERSION =' src/defines.pri | awk '{print $3}')
- printf "%s.r%s.g%s" "$version" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- sed -i "s/lib64/lib/g" qactus/src/qobs/qobs.pro
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/v//g'
}
build() {
cd qactus
- qmake-qt5 PREFIX=/usr qactus.pro
+ cmake . \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
make
}
package() {
- make -C qactus INSTALL_ROOT="${pkgdir}" install
+ make -C qactus DESTDIR="${pkgdir}" install
}