summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip2016-04-28 13:44:18 +0200
committerJosip2016-04-28 13:44:18 +0200
commit4a34dab0274b4ba23d5498bd9579f25371fe148e (patch)
tree5680c1a4c3c0aa8ff2f5996ce4a2e1b20d0de113
parent651aa3426eb56df18bfaf5e5e30e2840b0d4f3a7 (diff)
downloadaur-4a34dab0274b4ba23d5498bd9579f25371fe148e.tar.gz
Use hooks...
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD29
-rw-r--r--qactus.install12
3 files changed, 10 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e7a9e9f4532..a3100fd971f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,13 +3,11 @@ pkgbase = qactus-git
pkgver = v0.6.0.r1.gd99d5cd
pkgrel = 1
url = https://github.com/javierllorente/qactus
- install = qactus.install
arch = i686
arch = x86_64
license = GPL2
license = GPL3
makedepends = git
- makedepends = harfbuzz
depends = qtkeychain-qt5
provides = qactus
conflicts = qactus
diff --git a/PKGBUILD b/PKGBUILD
index efe0ece64425..84cd1e41df49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,33 +9,24 @@ arch=('i686' 'x86_64')
url="https://github.com/javierllorente/qactus"
license=('GPL2' 'GPL3')
depends=('qtkeychain-qt5')
-makedepends=('git' 'harfbuzz')
-conflicts=("${pkgname%-*}")
-provides=("${pkgname%-*}")
-install="${pkgname%-*}.install"
+makedepends=('git')
+conflicts=('qactus')
+provides=('qactus')
source=('git://github.com/javierllorente/qactus.git')
md5sums=('SKIP')
pkgver() {
- cd "${pkgname%-*}"
-
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ cd qactus
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd "${pkgname%-*}"
-
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build && cd build
-
- qmake-qt5 PREFIX=/usr ../qactus.pro
- make
+ cd qactus
+ qmake-qt5 PREFIX=/usr qactus.pro
+ make
}
package() {
- cd "${pkgname%-*}"/build
-
- make INSTALL_ROOT="${pkgdir}" install
+ cd qactus
+ make INSTALL_ROOT="${pkgdir}" install
}
diff --git a/qactus.install b/qactus.install
deleted file mode 100644
index 4f1d6880a66a..000000000000
--- a/qactus.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_install() {
- xdg-icon-resource forceupdate --theme hicolor &> /dev/null
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-} \ No newline at end of file