summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavić2015-06-16 20:53:15 +0200
committerJosip Ponjavić2015-06-16 20:53:15 +0200
commit651aa3426eb56df18bfaf5e5e30e2840b0d4f3a7 (patch)
tree82fbdc857113707db05e7750f634ff5f89714445
downloadaur-651aa3426eb56df18bfaf5e5e30e2840b0d4f3a7.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
-rw-r--r--qactus.install12
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e7a9e9f4532
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = qactus-git
+ pkgdesc = A Qt-based OBS notifier application.
+ pkgver = v0.6.0.r1.gd99d5cd
+ pkgrel = 1
+ url = https://github.com/javierllorente/qactus
+ install = qactus.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = GPL3
+ makedepends = git
+ makedepends = harfbuzz
+ depends = qtkeychain-qt5
+ provides = qactus
+ conflicts = qactus
+ source = git://github.com/javierllorente/qactus.git
+ md5sums = SKIP
+
+pkgname = qactus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efe0ece64425
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
+# Contributor:
+
+pkgname=qactus-git
+pkgver=v0.6.0.r1.gd99d5cd
+pkgrel=1
+pkgdesc="A Qt-based OBS notifier application."
+arch=('i686' 'x86_64')
+url="https://github.com/javierllorente/qactus"
+license=('GPL2' 'GPL3')
+depends=('qtkeychain-qt5')
+makedepends=('git' 'harfbuzz')
+conflicts=("${pkgname%-*}")
+provides=("${pkgname%-*}")
+install="${pkgname%-*}.install"
+source=('git://github.com/javierllorente/qactus.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-*}"
+
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname%-*}"
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ qmake-qt5 PREFIX=/usr ../qactus.pro
+ make
+}
+
+package() {
+ cd "${pkgname%-*}"/build
+
+ make INSTALL_ROOT="${pkgdir}" install
+}
diff --git a/qactus.install b/qactus.install
new file mode 100644
index 000000000000..4f1d6880a66a
--- /dev/null
+++ b/qactus.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file