summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2021-08-30 16:36:47 -0400
committerTed Alff2021-08-30 16:36:47 -0400
commitc799d5df2eebe8f140a8d4ea115adacf0e0e0a4a (patch)
treee7bcd44dde0716ad82baa2e959cc8433ab49b4a2
downloadaur-c799d5df2eebe8f140a8d4ea115adacf0e0e0a4a.tar.gz
Origial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17bf52474750
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = qalculate-qt5
+ pkgdesc = Qt5 frontend for libqalculate
+ pkgver = 3.20.1
+ pkgrel = 1
+ url = https://qalculate.github.io/
+ arch = x86_64
+ arch = i686
+ arch = aarch64
+ arch = armv7h
+ license = GPL
+ depends = libqalculate
+ depends = qt5-svg
+ depends = hicolor-icon-theme
+ source = https://github.com/Qalculate/qalculate-qt/releases/download/v3.20.1/qalculate-qt-3.20.1.tar.gz
+ sha256sums = 189e952b2b6b99ef63db46bd70d31f140adf19e8364d0eb4064daefca6a16e8a
+
+pkgname = qalculate-qt5
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ece1cfc23e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+_pkgname=qalculate-qt
+pkgname=${_pkgname}5
+pkgver=3.20.1
+pkgrel=1
+pkgdesc='Qt5 frontend for libqalculate'
+arch=('x86_64' 'i686' 'aarch64' 'armv7h')
+url='https://qalculate.github.io/'
+license=('GPL')
+depends=('libqalculate' 'qt5-svg' 'hicolor-icon-theme')
+source=("https://github.com/Qalculate/qalculate-qt/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('189e952b2b6b99ef63db46bd70d31f140adf19e8364d0eb4064daefca6a16e8a')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ qmake-qt5 PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ make INSTALL_ROOT="${pkgdir}" install
+}