summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-03-27 00:17:11 +0100
committerMarcell Meszaros2022-03-27 00:18:03 +0100
commit06300aaa4d843ed01864c3f144143e0e4ec4f8b6 (patch)
tree316ddaf99062749ac3cf2d6c512c1eec231ac170
parente2c95882fda39e360cbace568c811f62981c60e9 (diff)
downloadaur-06300aaa4d843ed01864c3f144143e0e4ec4f8b6.tar.gz
cmake: use CPPFLAGS and LDFLAGS
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD28
2 files changed, 20 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52e372312252..3dc3d337db01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qbittorrent-enhanced-qt5-git
pkgdesc = Bittorrent client using Qt5 and libtorrent-rasterbar, Enhanced Edition mod
pkgver = 4.4.2.10.r0.gdb18496c9
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/c0re100/qBittorrent-Enhanced-Edition
arch = arm
arch = armv6h
@@ -12,6 +12,7 @@ pkgbase = qbittorrent-enhanced-qt5-git
license = custom:GPL with OpenSSL exception
makedepends = boost
makedepends = cmake
+ makedepends = ninja
makedepends = qt5-svg
makedepends = qt5-tools
depends = dbus
diff --git a/PKGBUILD b/PKGBUILD
index ec4e05361903..685abefcbe42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Marcell Meszaros < marcell.meszaros AT runbox.eu >
-pkgname=qbittorrent-enhanced-qt5-git
+pkgname='qbittorrent-enhanced-qt5-git'
pkgver=4.4.2.10.r0.gdb18496c9
-pkgrel=3
+pkgrel=4
pkgdesc='Bittorrent client using Qt5 and libtorrent-rasterbar, Enhanced Edition mod'
arch=('arm' 'armv6h' 'armv7h' 'aarch64' 'i686' 'x86_64')
url='https://github.com/c0re100/qBittorrent-Enhanced-Edition'
@@ -17,6 +17,7 @@ depends=('dbus'
'zlib')
makedepends=('boost'
'cmake'
+ 'ninja'
'qt5-svg'
'qt5-tools')
optdepends=('python: needed for torrent search tab')
@@ -52,26 +53,33 @@ prepare() {
if check_buildoption "ccache" "y"; then
printf 'yes\n'
printf 'Enabling C++ ccache for CMake...\n'
- export CMAKE_CXX_COMPILER_LAUNCHER=ccache
+ export CMAKE_CXX_COMPILER_LAUNCHER='ccache'
else
printf 'no\n'
fi
printf 'Configuring build with CMake...\n\n'
- cmake -S "${_srcrepodir}" -B build \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DQT6=OFF \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DVERBOSE_CONFIGURE=ON
+ export CXXFLAGS+=" ${CPPFLAGS}" # CMake ignores CPPFLAGS
+
+ cmake -S "${_srcrepodir}" \
+ -B 'build' \
+ -G 'Ninja' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DQT6='OFF' \
+ -DCMAKE_BUILD_TYPE='RelWithDebInfo' \
+ -DCMAKE_EXE_LINKER_FLAGS_INIT="${LDFLAGS}" \
+ -DCMAKE_SHARED_LINKER_FLAGS_INIT="${LDFLAGS}" \
+ -DCMAKE_MODULE_LINKER_FLAGS_INIT="${LDFLAGS}" \
+ -DVERBOSE_CONFIGURE='ON'
}
build() {
printf 'Building with CMake...\n\n'
- cmake --build build
+ cmake --build 'build'
}
package() {
printf 'Installing with CMake...\n\n'
- DESTDIR="${pkgdir}" cmake --install build
+ DESTDIR="${pkgdir}" cmake --install 'build'
install -Dm644 "${_srcrepodir}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}