summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2017-07-10 12:27:10 -0400
committerEli Schwartz2017-07-10 12:27:10 -0400
commit87d6106b48b44c8a692855890323ffb668ee05f7 (patch)
tree17cc2e4442cf87937b1593beb3a93aaf25725146
parenta23414b669710b8419a9d295c9bcaf3e70000b79 (diff)
downloadaur-87d6106b48b44c8a692855890323ffb668ee05f7.tar.gz
upgpkg: qbittorrent-git 3.3.13.r1465.g3d970399d-1
fix compilation until libtorrent-rasterbar 1.1.4 is released to [extra]
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4d44f50d71c..ec7f58d4c539 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qbittorrent-git
pkgdesc = A bittorrent client powered by C++, Qt5 and the good libtorrent library (development version)
- pkgver = 3.3.13.r1414.g66aeafdc6
- pkgrel = 2
+ pkgver = 3.3.13.r1465.g3d970399d
+ pkgrel = 1
url = http://www.qbittorrent.org/
arch = i686
arch = x86_64
@@ -16,7 +16,9 @@ pkgbase = qbittorrent-git
provides = qbittorrent
conflicts = qbittorrent
source = qbittorrent::git+https://github.com/qbittorrent/qBittorrent.git
+ source = https://github.com/qbittorrent/qBittorrent/pull/7017.patch
sha256sums = SKIP
+ sha256sums = 83844864e7010c1f5c45eb5798c607e421e46a277270f78fa6b9c5fe93fe101a
pkgname = qbittorrent-git
diff --git a/PKGBUILD b/PKGBUILD
index 2ba66731a560..e7e8875075a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=qbittorrent-git
-pkgver=3.3.13.r1414.g66aeafdc6
-pkgrel=2
+pkgver=3.3.13.r1465.g3d970399d
+pkgrel=1
pkgdesc="A bittorrent client powered by C++, Qt5 and the good libtorrent library (development version)"
arch=('i686' 'x86_64')
url="http://www.qbittorrent.org/"
@@ -16,8 +16,10 @@ makedepends=('boost' 'git' 'qt5-tools')
optdepends=('python: needed for torrent search tab')
conflicts=('qbittorrent')
provides=('qbittorrent')
-source=("${pkgname%-*}::git+https://github.com/qbittorrent/qBittorrent.git")
-sha256sums=('SKIP')
+source=("${pkgname%-*}::git+https://github.com/qbittorrent/qBittorrent.git"
+ "https://github.com/qbittorrent/qBittorrent/pull/7017.patch")
+sha256sums=('SKIP'
+ '83844864e7010c1f5c45eb5798c607e421e46a277270f78fa6b9c5fe93fe101a')
pkgver() {
cd ${pkgname%-*}
@@ -28,6 +30,14 @@ pkgver() {
printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash"
}
+prepare() {
+ cd ${pkgname%-*}
+
+ # New feature exposed bug that is now fixed in libtorrent-rasterbar 1.1.4
+ # (flagged on archweb)
+ patch -Np1 < ../7017.patch
+}
+
build() {
cd ${pkgname%-*}