summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViliam Pucik2015-12-30 17:35:22 +0100
committerViliam Pucik2015-12-30 17:35:22 +0100
commit416c5e289cae2b7468b0315aeed1fe92f17d45fb (patch)
tree0643aae5ae19a3e5dca364448728814cc1e0c482
downloadaur-416c5e289cae2b7468b0315aeed1fe92f17d45fb.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD37
-rw-r--r--qbittorrent-qt4.install13
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f14f3ac6f78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Wed Dec 30 16:34:40 UTC 2015
+pkgbase = qbittorrent-qt4
+ pkgdesc = A bittorrent client written in C++ / Qt4 using the good libtorrent library
+ pkgver = 3.3.1
+ pkgrel = 1
+ url = http://www.qbittorrent.org
+ install = qbittorrent-qt4.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ license = GPL
+ makedepends = boost
+ makedepends = qt4
+ depends = libtorrent-rasterbar
+ depends = qt4
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = xdg-utils
+ optdepends = python: needed for torrent search tab
+ conflicts = qbittorrent
+ source = http://downloads.sourceforge.net/sourceforge/qbittorrent/qbittorrent-3.3.1.tar.xz
+ sha256sums = dad15a233a69ce13ea75957585af3f9122dbf915291aab0fdbc48a71b8a229d2
+
+pkgname = qbittorrent-qt4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..669806bea6c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id$
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: Jkkyll Wu <adaptee at gmail [dot] com>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Geoffroy Carrier <geoffroy.carrier@koon.fr>
+
+name=qbittorrent
+pkgname=${name}-qt4
+pkgver=3.3.1
+pkgrel=1
+pkgdesc="A bittorrent client written in C++ / Qt4 using the good libtorrent library"
+arch=('i686' 'x86_64')
+url="http://www.qbittorrent.org"
+license=('custom' 'GPL')
+depends=('libtorrent-rasterbar' 'qt4' 'desktop-file-utils' 'hicolor-icon-theme' 'xdg-utils')
+makedepends=('boost' 'qt4')
+optdepends=('python: needed for torrent search tab')
+conflicts=(${name})
+install=$pkgname.install
+source=("http://downloads.sourceforge.net/sourceforge/qbittorrent/$name-$pkgver.tar.xz")
+sha256sums=('dad15a233a69ce13ea75957585af3f9122dbf915291aab0fdbc48a71b8a229d2')
+
+build() {
+ cd $name-$pkgver
+
+ ./configure --prefix=/usr --with-qt4
+ make
+}
+
+package() {
+ cd $name-$pkgver
+
+ make INSTALL_ROOT="$pkgdir/" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$name/COPYING
+}
diff --git a/qbittorrent-qt4.install b/qbittorrent-qt4.install
new file mode 100644
index 000000000000..3f676f0a189f
--- /dev/null
+++ b/qbittorrent-qt4.install
@@ -0,0 +1,13 @@
+
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}