summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViliam Pucik2016-07-22 07:20:54 +0200
committerViliam Pucik2016-07-22 07:20:54 +0200
commit5de915faca6d81a2d7fd0243190944cc73dd824e (patch)
tree5fe70f088545773bde1bf60fb5b5d1f9fc306dc0
parent8ad978e78a077e538ca1174d44b91e084e6cad9b (diff)
downloadaur-5de915faca6d81a2d7fd0243190944cc73dd824e.tar.gz
Update to 3.3.6
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--qbittorrent-gcc6.patch14
3 files changed, 7 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb77d62cac74..b066644077bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jun 24 08:24:13 UTC 2016
+# Fri Jul 22 05:20:03 UTC 2016
pkgbase = qbittorrent-qt4
pkgdesc = A bittorrent client written in C++ / Qt4 using the good libtorrent library
- pkgver = 3.3.5
+ pkgver = 3.3.6
pkgrel = 2
url = http://www.qbittorrent.org
install = qbittorrent-qt4.install
@@ -19,10 +19,8 @@ pkgbase = qbittorrent-qt4
depends = xdg-utils
optdepends = python: needed for torrent search tab
conflicts = qbittorrent
- source = http://downloads.sourceforge.net/sourceforge/qbittorrent/qbittorrent-3.3.5.tar.xz
- source = qbittorrent-gcc6.patch
- md5sums = a1aaf4b7789906385861cd2e1a4a206d
- md5sums = 6f6ab8ccad907521f384c356faefe41e
+ source = http://downloads.sourceforge.net/sourceforge/qbittorrent/qbittorrent-3.3.6.tar.xz
+ md5sums = 246195ff8a5e44be8ecfcc8a7c01b5a9
pkgname = qbittorrent-qt4
diff --git a/PKGBUILD b/PKGBUILD
index 35043cb12e78..98f62d8e6f05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
name=qbittorrent
pkgname=${name}-qt4
-pkgver=3.3.5
+pkgver=3.3.6
pkgrel=2
pkgdesc="A bittorrent client written in C++ / Qt4 using the good libtorrent library"
arch=('i686' 'x86_64')
@@ -19,14 +19,7 @@ makedepends=('boost' 'qt4')
optdepends=('python: needed for torrent search tab')
conflicts=(${name})
install=$pkgname.install
-source=("http://downloads.sourceforge.net/sourceforge/qbittorrent/$name-$pkgver.tar.xz" 'qbittorrent-gcc6.patch')
-
-prepare() {
- cd $name-$pkgver
- # Fix build with GCC 6 (Fedora)
- patch -p1 -i ../qbittorrent-gcc6.patch
- ./bootstrap.sh
-}
+source=("http://downloads.sourceforge.net/sourceforge/qbittorrent/$name-$pkgver.tar.xz")
build() {
cd $name-$pkgver
@@ -41,5 +34,4 @@ package() {
make INSTALL_ROOT="$pkgdir/" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$name/COPYING
}
-md5sums=('a1aaf4b7789906385861cd2e1a4a206d'
- '6f6ab8ccad907521f384c356faefe41e')
+md5sums=('246195ff8a5e44be8ecfcc8a7c01b5a9')
diff --git a/qbittorrent-gcc6.patch b/qbittorrent-gcc6.patch
deleted file mode 100644
index 6bb6a9a600a7..000000000000
--- a/qbittorrent-gcc6.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -up qBittorrent-release-3.3.3/configure.ac.gcc6 qBittorrent-release-3.3.3/configure.ac
---- qBittorrent-release-3.3.3/configure.ac.gcc6 2016-01-20 16:49:39.000000000 -0600
-+++ qBittorrent-release-3.3.3/configure.ac 2016-03-13 07:45:03.512293512 -0500
-@@ -157,8 +157,8 @@ AX_BOOST_BASE([1.35])
- AS_IF([test "x$BOOST_CPPFLAGS" = "x"],
- [AC_MSG_ERROR([Could not find Boost])],
- [AC_MSG_NOTICE([Boost CPPFLGAS: $BOOST_CPPFLAGS])
-- CPPFLAGS="$BOOST_CPPFLAGS $CPPFLAGS"
-- LDFLAGS="$BOOST_LDFLAGS $LDFLAGS"])
-+ #CPPFLAGS="$BOOST_CPPFLAGS $CPPFLAGS"
-+ #LDFLAGS="$BOOST_LDFLAGS $LDFLAGS"])
-
- AX_BOOST_SYSTEM()
- # HAVE_BOOST_SYSTEM is set to an empty value when Boost.System is found.