summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViliam Pucik2016-06-24 10:24:42 +0200
committerViliam Pucik2016-06-24 10:25:30 +0200
commit8ad978e78a077e538ca1174d44b91e084e6cad9b (patch)
treeef1ce9e63a012bf37803ef010b6abc58d994cb73
parent188a1a3ff20c18d9bd2725ea0e7d721e7dc078d6 (diff)
downloadaur-8ad978e78a077e538ca1174d44b91e084e6cad9b.tar.gz
Fixed gcc 6 issue
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--qbittorrent-gcc6.patch14
3 files changed, 29 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e32e39fa718..fb77d62cac74 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jun 24 07:51:47 UTC 2016
+# Fri Jun 24 08:24:13 UTC 2016
pkgbase = qbittorrent-qt4
pkgdesc = A bittorrent client written in C++ / Qt4 using the good libtorrent library
pkgver = 3.3.5
- pkgrel = 1
+ pkgrel = 2
url = http://www.qbittorrent.org
install = qbittorrent-qt4.install
arch = i686
@@ -20,7 +20,9 @@ pkgbase = qbittorrent-qt4
optdepends = python: needed for torrent search tab
conflicts = qbittorrent
source = http://downloads.sourceforge.net/sourceforge/qbittorrent/qbittorrent-3.3.5.tar.xz
+ source = qbittorrent-gcc6.patch
md5sums = a1aaf4b7789906385861cd2e1a4a206d
+ md5sums = 6f6ab8ccad907521f384c356faefe41e
pkgname = qbittorrent-qt4
diff --git a/PKGBUILD b/PKGBUILD
index 2f26c47bc76c..35043cb12e78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
name=qbittorrent
pkgname=${name}-qt4
pkgver=3.3.5
-pkgrel=1
+pkgrel=2
pkgdesc="A bittorrent client written in C++ / Qt4 using the good libtorrent library"
arch=('i686' 'x86_64')
url="http://www.qbittorrent.org"
@@ -19,7 +19,14 @@ makedepends=('boost' 'qt4')
optdepends=('python: needed for torrent search tab')
conflicts=(${name})
install=$pkgname.install
-source=("http://downloads.sourceforge.net/sourceforge/qbittorrent/$name-$pkgver.tar.xz")
+source=("http://downloads.sourceforge.net/sourceforge/qbittorrent/$name-$pkgver.tar.xz" 'qbittorrent-gcc6.patch')
+
+prepare() {
+ cd $name-$pkgver
+ # Fix build with GCC 6 (Fedora)
+ patch -p1 -i ../qbittorrent-gcc6.patch
+ ./bootstrap.sh
+}
build() {
cd $name-$pkgver
@@ -34,4 +41,5 @@ package() {
make INSTALL_ROOT="$pkgdir/" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$name/COPYING
}
-md5sums=('a1aaf4b7789906385861cd2e1a4a206d')
+md5sums=('a1aaf4b7789906385861cd2e1a4a206d'
+ '6f6ab8ccad907521f384c356faefe41e')
diff --git a/qbittorrent-gcc6.patch b/qbittorrent-gcc6.patch
new file mode 100644
index 000000000000..6bb6a9a600a7
--- /dev/null
+++ b/qbittorrent-gcc6.patch
@@ -0,0 +1,14 @@
+diff -up qBittorrent-release-3.3.3/configure.ac.gcc6 qBittorrent-release-3.3.3/configure.ac
+--- qBittorrent-release-3.3.3/configure.ac.gcc6 2016-01-20 16:49:39.000000000 -0600
++++ qBittorrent-release-3.3.3/configure.ac 2016-03-13 07:45:03.512293512 -0500
+@@ -157,8 +157,8 @@ AX_BOOST_BASE([1.35])
+ AS_IF([test "x$BOOST_CPPFLAGS" = "x"],
+ [AC_MSG_ERROR([Could not find Boost])],
+ [AC_MSG_NOTICE([Boost CPPFLGAS: $BOOST_CPPFLAGS])
+- CPPFLAGS="$BOOST_CPPFLAGS $CPPFLAGS"
+- LDFLAGS="$BOOST_LDFLAGS $LDFLAGS"])
++ #CPPFLAGS="$BOOST_CPPFLAGS $CPPFLAGS"
++ #LDFLAGS="$BOOST_LDFLAGS $LDFLAGS"])
+
+ AX_BOOST_SYSTEM()
+ # HAVE_BOOST_SYSTEM is set to an empty value when Boost.System is found.