summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorselpats2022-01-09 18:02:08 +0400
committerselpats2022-01-09 18:02:08 +0400
commit093b69276d5784cd3e15c35a579ab943a39ec24c (patch)
tree240182372c9ead79b4dd0bbd4fa2d40e61ba01d9
downloadaur-093b69276d5784cd3e15c35a579ab943a39ec24c.tar.gz
init commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a8fdfc0a22c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = qbittorrent-qt5
+ pkgdesc = A bittorrent client powered by C++, Qt5 and the good libtorrent library
+ pkgver = 4.4.0
+ pkgrel = 1
+ url = https://www.qbittorrent.org/
+ arch = x86_64
+ license = custom
+ license = GPL
+ makedepends = boost
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = hicolor-icon-theme
+ depends = libtorrent-rasterbar
+ depends = qt5-base
+ depends = qt5-svg
+ optdepends = python: needed for torrent search tab
+ provides = qbittorrent
+ conflicts = qbittorrent
+ source = https://downloads.sourceforge.net/sourceforge/qbittorrent/qbittorrent-4.4.0.tar.xz
+ sha256sums = 6b783a88c7bd567e48cd9f20c67b788776ee2a6d474fe3df4af216acbdfe501b
+
+pkgname = qbittorrent-qt5
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7959053a262
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: selpast <selpast@pm.me>
+
+pkgname=qbittorrent-qt5
+pkgver=4.4.0
+pkgrel=1
+pkgdesc='A bittorrent client powered by C++, Qt5 and the good libtorrent library'
+arch=(x86_64)
+url='https://www.qbittorrent.org/'
+license=(custom GPL)
+depends=(hicolor-icon-theme libtorrent-rasterbar qt5-base qt5-svg)
+makedepends=(boost cmake qt5-tools)
+optdepends=('python: needed for torrent search tab')
+conflicts=('qbittorrent')
+provides=('qbittorrent')
+source=(https://downloads.sourceforge.net/sourceforge/qbittorrent/${pkgname%-*}-${pkgver}.tar.xz)
+sha256sums=('6b783a88c7bd567e48cd9f20c67b788776ee2a6d474fe3df4af216acbdfe501b')
+build() {
+ cd ${pkgname%-*}-${pkgver}
+
+ # tell qmake not to break makepkg's debug/!strip options
+ export QBT_ADD_CONFIG='nostrip'
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname%-*}-${pkgver}
+
+ make INSTALL_ROOT="${pkgdir}" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+} \ No newline at end of file