summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorselpats2022-02-16 20:35:15 +0400
committerselpats2022-02-16 20:35:15 +0400
commitea928237eaa678ee235ba9688b084c2363fe2de9 (patch)
treea369bc3c58eb93d02873c105af9a8cd12c7dd9fe
parent5e16857a6075490dac0629c4270504a2679eae54 (diff)
downloadaur-ea928237eaa678ee235ba9688b084c2363fe2de9.tar.gz
4.4.1 update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d72e55de2711..ff96e6eb0a04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qbittorrent-qt5
pkgdesc = An advanced BitTorrent client programmed in C++, based on Qt5 toolkit and libtorrent-rasterbar
- pkgver = 4.4.0
- pkgrel = 4
+ pkgver = 4.4.1
+ pkgrel = 1
url = https://www.qbittorrent.org
arch = x86_64
license = custom
@@ -16,10 +16,10 @@ pkgbase = qbittorrent-qt5
optdepends = python: needed for torrent search tab
provides = qbittorrent
conflicts = qbittorrent
- source = https://downloads.sourceforge.net/sourceforge/qbittorrent/qbittorrent-4.4.0.tar.xz
- source = https://downloads.sourceforge.net/sourceforge/qbittorrent/qbittorrent-4.4.0.tar.xz.asc
+ source = https://downloads.sourceforge.net/sourceforge/qbittorrent/qbittorrent-4.4.1.tar.xz
+ source = https://downloads.sourceforge.net/sourceforge/qbittorrent/qbittorrent-4.4.1.tar.xz.asc
validpgpkeys = D8F3DA77AAC6741053599C136E4A2D025B7CC9A2
- sha256sums = 6b783a88c7bd567e48cd9f20c67b788776ee2a6d474fe3df4af216acbdfe501b
+ sha256sums = 1386f000ce1d791469c3ea03e3951ca25f67f534e66896592bd12357dda9a8ec
sha256sums = SKIP
pkgname = qbittorrent-qt5
diff --git a/PKGBUILD b/PKGBUILD
index 4c34fed0b763..3c9bddeec9a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: selpast <selpast@pm.me>
pkgname=qbittorrent-qt5
-pkgver=4.4.0
-pkgrel=4
+pkgver=4.4.1
+pkgrel=1
pkgdesc='An advanced BitTorrent client programmed in C++, based on Qt5 toolkit and libtorrent-rasterbar'
arch=(x86_64)
url='https://www.qbittorrent.org'
@@ -13,22 +13,21 @@ optdepends=('python: needed for torrent search tab')
conflicts=('qbittorrent')
provides=('qbittorrent')
source=(https://downloads.sourceforge.net/sourceforge/qbittorrent/${pkgname%-*}-${pkgver}.tar.xz{,.asc})
-sha256sums=('6b783a88c7bd567e48cd9f20c67b788776ee2a6d474fe3df4af216acbdfe501b'
+sha256sums=('1386f000ce1d791469c3ea03e3951ca25f67f534e66896592bd12357dda9a8ec'
'SKIP')
validpgpkeys=('D8F3DA77AAC6741053599C136E4A2D025B7CC9A2')
build() {
cd ${pkgname%-*}-${pkgver}
- # tell qmake not to break makepkg's debug/!strip options
- export QBT_ADD_CONFIG='nostrip'
-
- ./configure --prefix=/usr
- make
+ cmake -B build -S . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DQT6=OFF
+ cmake --build build
}
package() {
cd ${pkgname%-*}-${pkgver}
- make INSTALL_ROOT="${pkgdir}" install
+ DESTDIR="$pkgdir" cmake --install build
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
} \ No newline at end of file