summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Rice2021-03-28 15:10:16 -0400
committerPeter Rice2021-03-28 15:10:16 -0400
commit8d0e4089d31384b5dc69ce9ef7757ca944070b76 (patch)
tree4c69399df0099c261d57fb9d48339f1e075a48d2
downloadaur-8d0e4089d31384b5dc69ce9ef7757ca944070b76.tar.gz
Initial upload
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81c51abd27af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = qbpm-git
+ pkgdesc = A profile manager for qutebrowser
+ pkgver = 0.3.r2.g8e35376
+ pkgrel = 1
+ url = https://github.com/pvsr/qbpm
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pyxdg
+ provides = qbpm
+ conflicts = qbpm
+ source = git://github.com/pvsr/qbpm
+ sha512sums = SKIP
+
+pkgname = qbpm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c76fb33c23db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Peter Rice <{first name}@peterrice.xyz>
+
+pkgname=qbpm-git
+pkgver=0.3.r2.g8e35376
+pkgrel=1
+pkgdesc="A profile manager for qutebrowser"
+url="https://github.com/pvsr/qbpm"
+license=('GPL')
+sha512sums=('SKIP')
+arch=('any')
+depends=('python' 'python-pyxdg')
+makedepends=('git' 'python-setuptools')
+provides=('qbpm')
+conflicts=('qbpm')
+source=("git://github.com/pvsr/qbpm")
+
+pkgver() {
+ cd qbpm
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd qbpm
+ install -D -m644 completions/qbpm.fish ${pkgdir}/usr/share/fish/vendor_completions.d/qbpm.fish
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/qbpm/LICENSE
+ python setup.py install --root="$pkgdir" --optimize=1
+}