summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2024-01-19 06:30:49 -0800
committerDonald Carr2024-01-19 06:31:16 -0800
commit9d9a0cbfde60a731462dd8269852e565f4ea29f4 (patch)
tree0382c25b429337cf0a4ce914017792186af31c51
parentc72357273aef8bbda72de053d633643046f8f8f5 (diff)
downloadaur-qbs-git.tar.gz
Fix up qbs-git recipe
Change-Id: I7661209b77ba1d2f61fcf6b2232c66100e93adce
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d90fb33874da..a9fa76a98cff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qbs-git
pkgdesc = Qt Build Suite: Build tool that helps simplify the build process for developing projects across multiple platforms.
- pkgver = v1.7.2.r297.g512704a5
+ pkgver = v2.2.1.r36.ge769597e5
pkgrel = 1
url = https://wiki.qt.io/Qt_Build_Suite
arch = x86_64
@@ -8,13 +8,13 @@ pkgbase = qbs-git
license = LGPL
makedepends = gcc
makedepends = git
- depends = qt5-base
- depends = qt5-script
+ depends = gcc-libs
+ depends = glibc
+ depends = qt6-base
+ depends = qt6-5compat
provides = qbs
- conflicts = qtcreator
conflicts = qbs
- source = git://code.qt.io/qbs/qbs.git
+ source = git+https://github.com/qbs/qbs.git
sha256sums = SKIP
pkgname = qbs-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 2b51e08a607d..740d11d4af0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,31 +6,32 @@
_pkgname=qbs
pkgname=${_pkgname}-git
-pkgver=v1.7.2.r297.g512704a5
+pkgver=v2.2.1.r36.ge769597e5
pkgrel=1
pkgdesc='Qt Build Suite: Build tool that helps simplify the build process for developing projects across multiple platforms.'
arch=('x86_64' 'i686')
url='https://wiki.qt.io/Qt_Build_Suite'
license=('LGPL')
provides=('qbs')
-conflicts=('qtcreator' 'qbs')
-depends=('qt5-base' 'qt5-script')
+conflicts=('qbs')
+depends=('gcc-libs' 'glibc' 'qt6-base' 'qt6-5compat')
makedepends=('gcc' 'git')
-source=("git://code.qt.io/qbs/qbs.git")
+source=("git+https://github.com/qbs/qbs.git")
sha256sums=('SKIP')
pkgver() {
- cd "$_pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$_pkgname"
- qmake QBS_INSTALL_PREFIX=/usr qbs.pro
- make
+ cd $_pkgname
+ mkdir -p build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr . -B build
+ cmake --build build
}
package() {
- cd "$_pkgname"
- INSTALL_ROOT="$pkgdir" make install
+ cd $_pkgname
+ DESTDIR=${pkgdir} cmake --install build
}