summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryozu2022-01-30 12:56:15 +0900
committeryozu2022-01-30 12:56:15 +0900
commite3928548145eb16fa172cf9ced4ada7eabfc3525 (patch)
tree0bb92be0c4ea0232743e7a96d5683021703bea44
parent4205d6788816b56a8246f4a583cc25ae186ef818 (diff)
downloadaur-e3928548145eb16fa172cf9ced4ada7eabfc3525.tar.gz
bump ver
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD15
-rw-r--r--patch.patch15
3 files changed, 24 insertions, 8 deletions
diff --git a/.gitignore b/.gitignore
index b06b3f791673..8b47e4826122 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-*.pkg.tar.xz
+*.pkg.*
src
pkg
qbsolv
diff --git a/PKGBUILD b/PKGBUILD
index c9567bf557cf..2053c8a2f813 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: yasuo-ozu <yasuo@ozu.email>
pkgname=qbsolv
-pkgver=0.2.10
+pkgver=0.3.4
pkgrel=1
pkgdesc='A decomposing solver that finds a minimum value of a large quadratic unconstrained binary optimization (QUBO) problem'
arch=('x86_64')
@@ -11,16 +11,17 @@ depends=()
optdepends=()
makedepends=(cmake make)
options=()
-source=("git+https://github.com/dwavesystems/${pkgname}")
-md5sums=('SKIP')
+source=("git+https://github.com/dwavesystems/${pkgname}" "patch.patch")
+md5sums=('SKIP' 'SKIP')
-pkgver() {
- cd "${pkgname}"
- cat setup.py|sed -ne '/^\s*version='\''.*'\'',$/p' | sed -e 's/^.*'\''\(.*\)'\'',$/\1/'
-}
+# pkgver() {
+# cd "${pkgname}"
+# cat setup.py|sed -ne '/^\s*version='\''.*'\'',$/p' | sed -e 's/^.*'\''\(.*\)'\'',$/\1/'
+# }
build() {
cd "${pkgname}"
+ git apply ../patch.patch
mkdir -p build
cd build
cmake -DQBSOLV_BUILD_CMD=ON ..
diff --git a/patch.patch b/patch.patch
new file mode 100644
index 000000000000..4ac88b88aa59
--- /dev/null
+++ b/patch.patch
@@ -0,0 +1,15 @@
+diff --git a/src/dwsolv.cc b/src/dwsolv.cc
+index 6234e9f..238d72f 100644
+--- a/src/dwsolv.cc
++++ b/src/dwsolv.cc
+@@ -48,8 +48,8 @@ int sysResult;
+ int start_;
+ int my_pid_;
+ char DWcommand[256];
+-FILE *f, *fr, *fs;
+-int i, j, k, l; // working integer set
++static FILE *f, *fr, *fs;
++static int i, j, k, l; // working integer set
+ //
+ // common declare complete, start function
+