summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2015-03-03 21:23:31 +0100
committerJohannes Dewender2015-03-03 21:23:31 +0100
commit40e1236c02413bcbb6f23e11d4df4f6e4a6ddb7d (patch)
treec9669345f7a69b804c1d777fdcc5fffe01447c03
downloadaur-40e1236c02413bcbb6f23e11d4df4f6e4a6ddb7d.tar.gz
qbzr: added as 0.23.0 from AUR
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD30
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f67bd8301a97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = qbzr
+ pkgdesc = A GUI front end for Bazaar based on the Qt toolkit.
+ pkgver = 0.23.0
+ pkgrel = 1
+ url = http://wiki.bazaar.canonical.com/QBzr
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2-pyqt>=4
+ depends = bzr
+ depends = python2
+ optdepends = python2-pygments: for syntax highlighting
+ optdepends = python2-pyenchant: for spell checking in commit dialogs
+ source = http://launchpad.net/qbzr/0.23/0.23.0/+download/qbzr-0.23.0.tar.gz
+ md5sums = bd000c87e9cfeb78ea6629a4bee65ee5
+
+pkgname = qbzr
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bd9b4a41adc0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.tar.gz
+*.tar.xz
+*.tgz
+*.rpm
+*.zip
+*.bz2
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6363520411e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer : sebikul <sebikul@gmail.com>
+#Contributed by Christian Rapp <saedelaere.tv@gmail.com>, based on:
+#Contributed by Peter Dennis <listen.ppublic@gmail.com>, based on PKGBUILD by:
+#Contributor: Ariel Kanterewicz <asdkant@gmail.com>
+
+pkgname=qbzr
+pkgver=0.23.0
+pkgrel=1
+pkgdesc="A GUI front end for Bazaar based on the Qt toolkit."
+arch=('i686' 'x86_64')
+url="http://wiki.bazaar.canonical.com/QBzr"
+license=('GPL')
+depends=('python2-pyqt>=4' 'bzr' 'python2')
+optdepends=('python2-pygments: for syntax highlighting'
+'python2-pyenchant: for spell checking in commit dialogs')
+
+source=("http://launchpad.net/${pkgname}/${pkgver%.*}/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz")
+md5sums=('bd000c87e9cfeb78ea6629a4bee65ee5')
+
+build() {
+
+ cd ${srcdir}/${pkgname}
+
+ sed -i -e "s=/usr/bin/env python=/usr/bin/env python2=g" ./setup.py
+
+ ./setup.py build || return 1
+
+ ./setup.py install --prefix=$pkgdir/usr install
+
+}