summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2018-10-17 16:07:17 +0200
committerStephan Springer2018-10-17 16:07:17 +0200
commit0c80420b701667fe80aae2ae2c294fc8877a98a9 (patch)
tree73aa7606dde19da28cd00cb73e7aef8fc9dd732a
parent0954df15c478a7d71fae2e4113cd8bb2b4b9c8df (diff)
downloadaur-0c80420b701667fe80aae2ae2c294fc8877a98a9.tar.gz
adopt; remove conflicts/provides/replaces
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD48
2 files changed, 24 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48b14c328e58..ce27d5bff907 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = qca-qt4
pkgdesc = Qt Cryptographic Architecture. Qt4 Build
pkgver = 2.1.3
- pkgrel = 1
+ pkgrel = 2
url = http://delta.affinix.com/qca/
arch = i686
arch = x86_64
license = LGPL
makedepends = cmake
makedepends = doxygen
- makedepends = git
makedepends = botan
makedepends = pkcs11-helper
makedepends = libsasl
@@ -17,15 +16,6 @@ pkgbase = qca-qt4
depends = nss
optdepends = pkcs11-helper: PKCS-11 plugin
optdepends = botan: botan plugin
- provides = qca
- provides = qca-gnupg
- provides = qca-ossl
- conflicts = qca
- conflicts = qca-gnupg
- conflicts = qca-ossl
- replaces = qca
- replaces = qca-gnupg
- replaces = qca-ossl
source = http://download.kde.org/stable/qca/2.1.3/src/qca-2.1.3.tar.xz
source = qca-openssl-1.1.patch
source = qca-botan2.patch::https://cgit.kde.org/qca.git/patch/?id=47163784
diff --git a/PKGBUILD b/PKGBUILD
index 8a18e82937f1..00680b1c069d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,45 @@
-# Maintainer: Samuel Fernando Mesa <samuel.mesa at linuxmail dot org>
+# Maintainer: Stephan Springer <buzo+arch@Lini.de>
+# Contributor: Samuel Fernando Mesa <samuel.mesa at linuxmail dot org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>s
pkgname=qca-qt4
_pkgname=qca
pkgver=2.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Qt Cryptographic Architecture. Qt4 Build"
arch=('i686' 'x86_64')
license=('LGPL')
-url=http://delta.affinix.com/qca/
+url='http://delta.affinix.com/qca/'
depends=(qt4 nss)
optdepends=('pkcs11-helper: PKCS-11 plugin' 'botan: botan plugin')
-conflicts=(qca qca-gnupg qca-ossl)
-provides=(qca qca-gnupg qca-ossl)
-replaces=(qca qca-gnupg qca-ossl)
-makedepends=('cmake' 'doxygen' 'git' 'botan' 'pkcs11-helper' 'libsasl' 'libgcrypt')
-source=("http://download.kde.org/stable/$_pkgname/$pkgver/src/$_pkgname-$pkgver.tar.xz" qca-openssl-1.1.patch qca-botan2.patch::"https://cgit.kde.org/qca.git/patch/?id=47163784")
+makedepends=('cmake' 'doxygen' 'botan' 'pkcs11-helper' 'libsasl' 'libgcrypt')
+source=("http://download.kde.org/stable/$_pkgname/$pkgver/src/$_pkgname-$pkgver.tar.xz"
+ qca-openssl-1.1.patch
+ qca-botan2.patch::"https://cgit.kde.org/qca.git/patch/?id=47163784")
sha256sums=('003fd86a32421057a03b18a8168db52e2940978f9db5ebbb6a08882f8ab1e353'
'b1505bc313fd2f4e350cd4c94af69256c901afa419ae6700b208cb6e40e6926d'
'2b2c3103e47166eee46604288ba343b9ed1ccb957c54650e8eea770faab515e9')
prepare() {
- mkdir -p build
- cd $_pkgname-$pkgver
- patch -p1 -i ../qca-openssl-1.1.patch # Fix build with OpenSSL 1.1 https://bugs.kde.org/show_bug.cgi?id=379810
- patch -p1 -i ../qca-botan2.patch # Fix build with botan 2
+ mkdir -p build
+ cd "$_pkgname-$pkgver"
+ patch -p1 -i ../qca-openssl-1.1.patch # Fix build with OpenSSL 1.1 https://bugs.kde.org/show_bug.cgi?id=379810
+ patch -p1 -i ../qca-botan2.patch # Fix build with botan 2
}
build() {
- cd build
-
- cmake ../$_pkgname-$pkgver \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_TESTS=OFF \
- -DQCA_LIBRARY_INSTALL_DIR=/usr/lib \
- -DQCA_FEATURE_INSTALL_DIR=/usr/share/qt4/mkspecs/features/ \
- -DQT4_BUILD=ON
-
- make
+ cd build
+ cmake ../"$_pkgname-$pkgver" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_TESTS=OFF \
+ -DQCA_LIBRARY_INSTALL_DIR=/usr/lib \
+ -DQCA_FEATURE_INSTALL_DIR=/usr/share/qt4/mkspecs/features/ \
+ -DQT4_BUILD=ON
+ make
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
-} \ No newline at end of file
+ cd build
+ make DESTDIR="$pkgdir" install
+}