summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 19:35:24 +0200
committersl1pkn072015-06-08 19:35:24 +0200
commit2a7c377238a30e362003e207a55e9efc10d30848 (patch)
treeae95c71c0999ab66d11c054445e6d478d74bd5a5
downloadaur-2a7c377238a30e362003e207a55e9efc10d30848.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..825d53847e80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = qca-qt5-git
+ pkgdesc = Qt Cryptographic Architecture. Qt5 Build (GIT Version)
+ pkgver = v2.1.0.23.g7207e62
+ pkgrel = 1
+ url = http://delta.affinix.com/qca/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ makedepends = doxygen
+ makedepends = git
+ makedepends = botan-1.10
+ makedepends = pkcs11-helper
+ makedepends = libsasl
+ makedepends = libgcrypt
+ depends = qt5-base
+ optdepends = botan-1.10: Botan plugin
+ optdepends = pkcs11-helper: PKCS11 plugin
+ optdepends = nss: nss plugin
+ optdepends = libsasl: SASL plugin
+ optdepends = libgcrypt: gcrypt plugin
+ provides = qca-qt5
+ conflicts = qca-qt5
+ source = git://anongit.kde.org/qca.git
+ md5sums = SKIP
+
+pkgname = qca-qt5-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..995b1ae378a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Antonio Rojas
+
+pkgname=qca-qt5-git
+pkgver=v2.1.0.23.g7207e62
+pkgrel=1
+pkgdesc="Qt Cryptographic Architecture. Qt5 Build (GIT Version)"
+arch=('i686' 'x86_64')
+license=('LGPL')
+url="http://delta.affinix.com/qca/"
+depends=('qt5-base' )
+makedepends=('cmake' 'doxygen' 'git' 'botan-1.10' 'pkcs11-helper' 'libsasl' 'libgcrypt')
+optdepends=('botan-1.10: Botan plugin'
+ 'pkcs11-helper: PKCS11 plugin'
+ 'nss: nss plugin'
+ 'libsasl: SASL plugin'
+ 'libgcrypt: gcrypt plugin')
+conflicts=('qca-qt5')
+provides=('qca-qt5')
+source=("git://anongit.kde.org/qca.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd qca
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+ sed 's|_BSD_SOURCE|_DEFAULT_SOURCE|g' -i qca/CMakeLists.txt
+}
+
+build() {
+ cd build
+ cmake ../qca \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DQCA_INSTALL_IN_QT_PREFIX=ON \
+ -DQCA_SUFFIX=qt5 \
+ -DBUILD_TESTS=OFF
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}