summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuben De Smet2016-11-07 14:33:35 +0100
committerRuben De Smet2016-11-07 14:33:35 +0100
commit15b9ef048baa592829e90c6be0a70e1765416640 (patch)
tree8a4de0a2f2e1c8ff7609d6a265514a0a382be197
downloadaur-15b9ef048baa592829e90c6be0a70e1765416640.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD59
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..132646d97b14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Nov 7 13:24:43 UTC 2016
+pkgbase = qccpack
+ pkgver = 0.61
+ pkgrel = 2
+ url = http://qccpack.sourceforge.net/
+ arch = any
+ license = LGPLv2
+ depends = texlive-core
+ depends = tex-gyre-fonts
+ depends = texlive-latexextra
+ options = !emptydirs
+ source = http://netcologne.dl.sourceforge.net/project/qccpack/QccPack/0.61/QccPack-0.61-1.tar.gz
+ sha512sums = 0f7f581c8f6489126251175389645ac1255bfdf380aeb2565e16503558edb93837fb907291bf7207ca40e32c3f2cc37bc0e36734add064ffa6d3be598432a435
+
+pkgname = qccpack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a909ae2689d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Ruben De Smet <ruben dot de dot smet at rubdos dot be>
+
+pkgname='qccpack'
+pkgver="0.61"
+pkgrel=2
+pkgdesc=''
+url='http://qccpack.sourceforge.net/'
+license=(
+ 'LGPL2'
+)
+source=(
+ 'http://netcologne.dl.sourceforge.net/project/qccpack/QccPack/0.61/QccPack-0.61-1.tar.gz'
+)
+sha512sums=(
+ '0f7f581c8f6489126251175389645ac1255bfdf380aeb2565e16503558edb93837fb907291bf7207ca40e32c3f2cc37bc0e36734add064ffa6d3be598432a435'
+)
+arch=(
+ 'i686'
+ 'x86_64'
+)
+depends=(
+ 'bash'
+ 'gcc-libs'
+)
+makedepends=(
+)
+checkdepends=(
+)
+options=(
+ '!emptydirs'
+)
+
+build() {
+ ls
+ pwd
+ cd QccPack/
+ cp QccPack.config.linux QccPack.config
+ sed -ie "s|/usr/local/src/QccPack|$(pwd)|" QccPack.config
+ sed -ie "s|QCCPACK_INSTALL = .*$|QCCPACK_INSTALL = ${pkgdir}/usr/|g" QccPack.config
+
+ imake
+ make Makefiles
+ make
+}
+
+package() {
+ cd QccPack
+ make install
+}
+
+post_install() {
+ ldconfig
+}
+
+post_remove() {
+ ldconfig
+}
+
+# vim: tabstop=1 expandtab