summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKimiblock Moe2024-04-06 15:31:08 +0800
committerKimiblock Moe2024-04-06 15:31:08 +0800
commit559b05384383d38b4d13685a56f5466fa8d5c45f (patch)
treec1448866608043085cd3885db28c999680ebc766
parent73fa0f2f415e08c8038e46ce39985746952f4c03 (diff)
downloadaur-559b05384383d38b4d13685a56f5466fa8d5c45f.tar.gz
Fix Icon issues
-rwxr-xr-x.SRCINFO2
-rwxr-xr-xPKGBUILD115
2 files changed, 55 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4c54c7032a4..0462fb723cde 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qcm-git
pkgdesc = Qt client for netease cloud music
pkgver = 1.0.2.r5.gab29b2cd
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/hypengw/Qcm
arch = x86_64
license = GPL-2.0-or-later
diff --git a/PKGBUILD b/PKGBUILD
index d28fc2c85c52..d5edce28401e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,83 +1,76 @@
# Maintainer: Kimiblock Moe
+# Contributor: Integral
+
pkgname=qcm-git
pkgver=1.0.2.r5.gab29b2cd
-pkgrel=1
+pkgrel=3
pkgdesc="Qt client for netease cloud music"
arch=('x86_64')
url="https://github.com/hypengw/Qcm"
license=('GPL-2.0-or-later')
depends=(
- 'qt6-base'
- 'qt6-shadertools'
- 'hicolor-icon-theme'
- 'curl'
- 'openssl'
- 'qt6-tools'
- 'qt6-declarative'
- 'gcc-libs'
- 'glibc'
- 'dbus'
- 'libnghttp2'
- 'libidn2'
- 'krb5'
- 'zstd'
- 'zlib'
- 'qt6-wayland'
- 'libx11'
- 'libxkbcommon'
- 'libpng'
- 'freetype2'
- 'icu'
- 'pcre2'
- 'gnutls'
- 'graphite'
- 'lz4'
- 'libgpg-error'
- 'ffmpeg')
+ 'qt6-base'
+ 'qt6-shadertools'
+ 'hicolor-icon-theme'
+ 'curl'
+ 'openssl'
+ 'qt6-tools'
+ 'qt6-declarative'
+ 'gcc-libs'
+ 'glibc'
+ 'dbus'
+ 'libnghttp2'
+ 'libidn2'
+ 'krb5'
+ 'zstd'
+ 'zlib'
+ 'qt6-wayland'
+ 'libx11'
+ 'libxkbcommon'
+ 'libpng'
+ 'freetype2'
+ 'icu'
+ 'pcre2'
+ 'gnutls'
+ 'graphite'
+ 'lz4'
+ 'libgpg-error'
+ 'ffmpeg')
makedepends=(
- 'git'
- 'cmake'
- 'extra-cmake-modules'
- 'ninja')
+ 'git'
+ 'cmake'
+ 'extra-cmake-modules'
+ 'ninja')
provides=("qcm")
source=('git+https://github.com/hypengw/Qcm.git')
sha256sums=('SKIP')
conflicts=("qcm")
+function prepare() {
+ cd Qcm
+ #git submodule update --init --depth 1 --remote
+ git submodule update --init
+ if [ -d "${srcdir}"/Qcm/build ]; then
+ rm -r "${srcdir}"/Qcm/build
+ fi
+}
+
function pkgver(){
- cd Qcm
- git describe --long --tags --abbrev=8 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd Qcm
+ git describe --long --tags --abbrev=8 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
function build(){
- if [ -d "${srcdir}"/Qcm/build ]; then
- _info "Deleting ${srcdir}/Qcm/build"
- rm -r "${srcdir}"/Qcm/build
- fi
- _info "Starting Build..."
- cd Qcm
- git submodule update --init
- mkdir build
- cd build
- cmake .. -GNinja -DCMAKE_BUILD_TYPE=Release
- ninja
+ cd Qcm
+ mkdir build
+ cd build
+ cmake .. -GNinja -DCMAKE_BUILD_TYPE=Release
+ ninja
}
function package(){
- _info "Copying files"
- install -Dm644 "${srcdir}/Qcm/app/assets/Qcm.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/io.github.hypengw.Qcm.svg"
- install -Dm644 "${srcdir}/Qcm/app/assets/Qcm.desktop" "${pkgdir}/usr/share/applications/Qcm.desktop"
- install -Dm755 "${srcdir}/Qcm/build/app/Qcm" "${pkgdir}/usr/bin/Qcm"
-}
-
-function _info() {
- if [ -f /usr/bin/pamac ]; then
- echo " ==> [Info]: $@"
- else
- all_off="$(tput sgr0)"
- bold="${all_off}$(tput bold)"
- blue="${bold}$(tput setaf 4)"
- yellow="${bold}$(tput setaf 3)"
- printf "${blue}==>${yellow} [Info]:${bold} $1${all_off}\n"
- fi
+ local appID=io.github.hypengw.Qcm
+ install -Dm644 "${srcdir}/Qcm/app/assets/Qcm.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${appID}.svg"
+ install -Dm644 "${srcdir}/Qcm/app/assets/Qcm.desktop" "${pkgdir}/usr/share/applications/${appID}.desktop"
+ install -Dm755 "${srcdir}/Qcm/build/app/Qcm" "${pkgdir}/usr/bin/Qcm"
}