summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKimiblock2023-05-06 15:32:51 +0800
committerKimiblock2023-05-06 15:32:51 +0800
commitced56d27a2e06a74334af71a85b44231099aa24d (patch)
tree58866dea10a90bacfc71b46374b816611f89101e
parente7a9902631cca993219e3da0cba4e0941f1eed36 (diff)
downloadaur-ced56d27a2e06a74334af71a85b44231099aa24d.tar.gz
Add dependencies and update SRCINFO
-rwxr-xr-x.SRCINFO24
-rwxr-xr-xPKGBUILD27
2 files changed, 47 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73d77fe108e4..7f5b87d4aa53 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = qcm-git
pkgdesc = Qt client for netease cloud music
- pkgver = r46.c085302
+ pkgver = r55.f39f015
pkgrel = 1
url = https://github.com/hypengw/Qcm
arch = x86_64
+ license = GPL2
makedepends = git
makedepends = cmake
+ makedepends = extra-cmake-modules
makedepends = ninja
depends = qt6-base
depends = hicolor-icon-theme
@@ -13,6 +15,26 @@ pkgbase = qcm-git
depends = openssl
depends = qt6-tools
depends = qt6-multimedia
+ depends = qt6-declarative
+ depends = gcc-libs
+ depends = glibc
+ depends = dbus
+ depends = libnghttp2
+ depends = libidn2
+ depends = krb5
+ depends = zstd
+ depends = zlib
+ depends = qt6-wayland
+ depends = libx11
+ depends = libxkbcommon
+ depends = libpng
+ depends = freetype2
+ depends = icu
+ depends = pcre2
+ depends = gnutls
+ depends = graphite
+ depends = lz4
+ depends = libgpg-error
provides = qcm
source = git+https://github.com/hypengw/Qcm.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c80b5ea696dd..4e4de896b78e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,38 @@
+# Maintainer: Kimiblock Zhou <pn3535 at icloud dot com>
pkgname=qcm-git
-pkgver=r46.c085302
+pkgver=r55.f39f015
pkgrel=1
pkgdesc="Qt client for netease cloud music "
arch=('x86_64')
url="https://github.com/hypengw/Qcm"
-License=('GPL2.0')
+license=('GPL2')
depends=(
'qt6-base'
'hicolor-icon-theme'
'curl'
'openssl'
'qt6-tools'
- 'qt6-multimedia')
+ 'qt6-multimedia'
+ 'qt6-declarative'
+ 'gcc-libs'
+ 'glibc'
+ 'dbus'
+ 'libnghttp2'
+ 'libidn2'
+ 'krb5'
+ 'zstd'
+ 'zlib'
+ 'qt6-wayland'
+ 'libx11'
+ 'libxkbcommon'
+ 'libpng'
+ 'freetype2'
+ 'icu'
+ 'pcre2'
+ 'gnutls'
+ 'graphite'
+ 'lz4'
+ 'libgpg-error')
makedepends=(
'git'
'cmake'