summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKimiblock2023-05-03 10:59:12 +0800
committerKimiblock2023-05-03 10:59:12 +0800
commite7a9902631cca993219e3da0cba4e0941f1eed36 (patch)
tree2febfeb612ec610ab65273a5e6ca8b4123354b0c
parentfa3bad521392b0dc65eaa898298b787195286d80 (diff)
downloadaur-e7a9902631cca993219e3da0cba4e0941f1eed36.tar.gz
Revert "Dark Mode Fix"
This reverts commit fa3bad521392b0dc65eaa898298b787195286d80. Upstream fixed dark mode
-rwxr-xr-x.SRCINFO5
-rwxr-xr-xPKGBUILD13
-rwxr-xr-xdark-mode.patch12
3 files changed, 4 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64ed84266fc3..73d77fe108e4 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = qcm-git
pkgdesc = Qt client for netease cloud music
- pkgver = r53.4e4d6de
+ pkgver = r46.c085302
pkgrel = 1
url = https://github.com/hypengw/Qcm
arch = x86_64
makedepends = git
makedepends = cmake
- makedepends = extra-cmake-modules
makedepends = ninja
depends = qt6-base
depends = hicolor-icon-theme
@@ -16,8 +15,6 @@ pkgbase = qcm-git
depends = qt6-multimedia
provides = qcm
source = git+https://github.com/hypengw/Qcm.git
- source = dark-mode.patch
sha256sums = SKIP
- sha256sums = 10da1a403bb52442107e68e6dbba1eabf8a922135ae82e2cb2758901994feb88
pkgname = qcm-git
diff --git a/PKGBUILD b/PKGBUILD
index def32cd17a2c..c80b5ea696dd 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=qcm-git
-pkgver=r53.4e4d6de
+pkgver=r46.c085302
pkgrel=1
pkgdesc="Qt client for netease cloud music "
arch=('x86_64')
@@ -18,13 +18,8 @@ makedepends=(
'extra-cmake-modules'
'ninja')
provides=("qcm")
-source=('git+https://github.com/hypengw/Qcm.git' 'dark-mode.patch')
-sha256sums=('SKIP' 'SKIP')
-
-function prepare(){
- cd "${srcdir}"/Qcm
- patch --forward --strip=1 --input="${srcdir}/dark-mode.patch"
-}
+source=('git+https://github.com/hypengw/Qcm.git')
+sha256sums=('SKIP')
function pkgver(){
cd Qcm
@@ -63,5 +58,3 @@ function _info() {
printf "${blue}==>${yellow} [Info]:${bold} $1${all_off}\n"
fi
}
-sha256sums=('SKIP'
- '10da1a403bb52442107e68e6dbba1eabf8a922135ae82e2cb2758901994feb88')
diff --git a/dark-mode.patch b/dark-mode.patch
deleted file mode 100755
index 8518788972cd..000000000000
--- a/dark-mode.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff '--color=auto' --unified --recursive --text Qcm/app/qml/Theme.qml Qcm-new/app/qml/Theme.qml
---- Qcm/app/qml/Theme.qml 2023-05-02 21:52:18.666643384 +0800
-+++ Qcm-new/app/qml/Theme.qml 2023-05-02 21:48:53.796376280 +0800
-@@ -68,7 +68,7 @@
- readonly property string trending_flat: '\ue8e4'
- }
- readonly property bool is_dark_theme: theme === MdColorMgr.Dark
-- readonly property alias theme: m_color.schemeTheme
-+ property alias theme: m_color.schemeTheme
- readonly property var ts: ({
- "title_small": {
- "size": 12