summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKimiblock2023-05-02 22:03:44 +0800
committerKimiblock2023-05-02 22:03:44 +0800
commitfa3bad521392b0dc65eaa898298b787195286d80 (patch)
tree0a97dd347dad7fcb6d500223e8288c88ca248ffa
parent6929320117cf2ea0173bc63f992645b530f73cc9 (diff)
downloadaur-fa3bad521392b0dc65eaa898298b787195286d80.tar.gz
Dark Mode Fix
-rwxr-xr-x.SRCINFO5
-rwxr-xr-xPKGBUILD13
-rwxr-xr-xdark-mode.patch12
3 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73d77fe108e4..64ed84266fc3 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = qcm-git
pkgdesc = Qt client for netease cloud music
- pkgver = r46.c085302
+ pkgver = r53.4e4d6de
pkgrel = 1
url = https://github.com/hypengw/Qcm
arch = x86_64
makedepends = git
makedepends = cmake
+ makedepends = extra-cmake-modules
makedepends = ninja
depends = qt6-base
depends = hicolor-icon-theme
@@ -15,6 +16,8 @@ pkgbase = qcm-git
depends = qt6-multimedia
provides = qcm
source = git+https://github.com/hypengw/Qcm.git
+ source = dark-mode.patch
sha256sums = SKIP
+ sha256sums = 10da1a403bb52442107e68e6dbba1eabf8a922135ae82e2cb2758901994feb88
pkgname = qcm-git
diff --git a/PKGBUILD b/PKGBUILD
index c80b5ea696dd..def32cd17a2c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=qcm-git
-pkgver=r46.c085302
+pkgver=r53.4e4d6de
pkgrel=1
pkgdesc="Qt client for netease cloud music "
arch=('x86_64')
@@ -18,8 +18,13 @@ makedepends=(
'extra-cmake-modules'
'ninja')
provides=("qcm")
-source=('git+https://github.com/hypengw/Qcm.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/hypengw/Qcm.git' 'dark-mode.patch')
+sha256sums=('SKIP' 'SKIP')
+
+function prepare(){
+ cd "${srcdir}"/Qcm
+ patch --forward --strip=1 --input="${srcdir}/dark-mode.patch"
+}
function pkgver(){
cd Qcm
@@ -58,3 +63,5 @@ function _info() {
printf "${blue}==>${yellow} [Info]:${bold} $1${all_off}\n"
fi
}
+sha256sums=('SKIP'
+ '10da1a403bb52442107e68e6dbba1eabf8a922135ae82e2cb2758901994feb88')
diff --git a/dark-mode.patch b/dark-mode.patch
new file mode 100755
index 000000000000..8518788972cd
--- /dev/null
+++ b/dark-mode.patch
@@ -0,0 +1,12 @@
+diff '--color=auto' --unified --recursive --text Qcm/app/qml/Theme.qml Qcm-new/app/qml/Theme.qml
+--- Qcm/app/qml/Theme.qml 2023-05-02 21:52:18.666643384 +0800
++++ Qcm-new/app/qml/Theme.qml 2023-05-02 21:48:53.796376280 +0800
+@@ -68,7 +68,7 @@
+ readonly property string trending_flat: '\ue8e4'
+ }
+ readonly property bool is_dark_theme: theme === MdColorMgr.Dark
+- readonly property alias theme: m_color.schemeTheme
++ property alias theme: m_color.schemeTheme
+ readonly property var ts: ({
+ "title_small": {
+ "size": 12