summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-01-16 21:02:58 +0100
committerGustavo Alvarez2016-01-16 21:02:58 +0100
commit8fdb50d833eb9cfb20e1680548f3f5586f75607b (patch)
tree34e90934329661f8d1a7c9bee9a0dd1d9991f949
parent3f0511eab6d92cb8ea0ca9b56894fd785fb8f9c3 (diff)
downloadaur-8fdb50d833eb9cfb20e1680548f3f5586f75607b.tar.gz
add appindicator plugin
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 27 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 672c1277324e..370a12150b9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Jan 16 19:56:25 UTC 2016
+# Sat Jan 16 20:02:41 UTC 2016
pkgbase = qcma-git
pkgdesc = Content Manager Assistant for the PS Vita. (GIT version)
pkgver = v0.3.10.0.g7886238
@@ -15,6 +15,7 @@ pkgbase = qcma-git
makedepends = ffmpeg
makedepends = libnotify
makedepends = knotifications
+ makedepends = libappindicator-gtk2
source = git+https://github.com/codestation/qcma.git
sha1sums = SKIP
@@ -36,3 +37,11 @@ pkgname = qcma-kdenotifier-git
provides = qcma-kdenotifier
conflicts = qcma-kdenotifier
+pkgname = qcma-appindicator-git
+ pkgdesc = Content Manager Assistant for the PS Vita. (appindicator) (GIT Version)
+ install = qcma-git.install
+ depends = qcma-git
+ depends = libappindicator-gtk2
+ provides = qcma-appindicator
+ conflicts = qcma-appindicator
+
diff --git a/PKGBUILD b/PKGBUILD
index c64af0b3f9d8..513865fff22f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,9 @@
# Contributor: codestation <codestation404@gmail.com>
pkgbase=qcma-git
-pkgname=('qcma-git' 'qcma-kdenotifier-git')
+pkgname=('qcma-git'
+ 'qcma-kdenotifier-git'
+ 'qcma-appindicator-git')
pkgver=v0.3.10.0.g7886238
pkgrel=1
pkgdesc="Content Manager Assistant for the PS Vita. (GIT version)"
@@ -16,6 +18,7 @@ makedepends=('git'
'ffmpeg'
'libnotify'
'knotifications'
+ 'libappindicator-gtk2'
)
source=('git+https://github.com/codestation/qcma.git')
sha1sums=('SKIP')
@@ -32,7 +35,7 @@ prepare() {
build() {
cd build
lrelease-qt5 "${srcdir}/qcma/common/resources/translations/"*.ts
- qmake-qt5 "${srcdir}/qcma/qcma.pro" PREFIX=/usr CONFIG+="ENABLE_KDENOTIFIER ENABLE_KNOTIFICATIONS"
+ qmake-qt5 "${srcdir}/qcma/qcma.pro" PREFIX=/usr CONFIG+="ENABLE_KDENOTIFIER ENABLE_KNOTIFICATIONS ENABLE_APPINDICATOR"
make
}
@@ -63,3 +66,15 @@ package_qcma-kdenotifier-git() {
make -C build/kdenotifier INSTALL_ROOT="${pkgdir}" install
}
+
+package_qcma-appindicator-git() {
+ pkgdesc="Content Manager Assistant for the PS Vita. (appindicator) (GIT Version)"
+ depends=('qcma-git'
+ 'libappindicator-gtk2'
+ )
+ conflicts=('qcma-appindicator')
+ provides=('qcma-appindicator')
+ install=qcma-git.install
+
+ make -C build/appindicator INSTALL_ROOT="${pkgdir}" install
+} \ No newline at end of file