summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 19:38:20 +0200
committersl1pkn072015-06-08 19:38:20 +0200
commitd7dd668d1fbe17a10500192dd7312f9c158c41fe (patch)
treedeb80fb7c23f4c924be6e977610d06c010720b8f
downloadaur-d7dd668d1fbe17a10500192dd7312f9c158c41fe.tar.gz
Initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD55
-rw-r--r--qcma-git.install13
4 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28f4c8d5b695
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = qcma-git
+ pkgdesc = Content Manager Assistant for the PS Vita. (GIT version)
+ pkgver = v0.3.9.5.g7ed5bac
+ pkgrel = 1
+ url = https://github.com/codestation/qcma
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = qt5-tools
+ makedepends = qt5-base
+ makedepends = vitamtpmod
+ makedepends = ffmpeg
+ makedepends = libnotify
+ makedepends = knotifications
+ source = git+https://github.com/codestation/qcma.git
+ sha1sums = SKIP
+
+pkgname = qcma-git
+ pkgdesc = Content Manager Assistant for the PS Vita. (GIT Version)
+ install = qcma-git.install
+ depends = ffmpeg
+ depends = qt5-base
+ depends = libnotify
+ depends = vitamtpmod
+ depends = hicolor-icon-theme
+ provides = qcma
+ conflicts = qcma
+
+pkgname = qcma-kdenotifier-git
+ pkgdesc = Content Manager Assistant for the PS Vita. (KDE notifier) (GIT Version)
+ depends = qcma-git
+ depends = knotifications
+ provides = qcma-kdenotifier
+ conflicts = qcma-kdenotifier
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f7f9c22cff35
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!qcma-git.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7a60960b951
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: codestation <codestation404@gmail.com>
+
+pkgbase=qcma-git
+pkgname=('qcma-git' 'qcma-kdenotifier-git')
+pkgver=v0.3.9.5.g7ed5bac
+pkgrel=1
+pkgdesc="Content Manager Assistant for the PS Vita. (GIT version)"
+arch=("i686" "x86_64")
+url="https://github.com/codestation/qcma"
+license=('GPL')
+makedepends=('git' 'qt5-tools' 'qt5-base' 'vitamtpmod' 'ffmpeg' 'libnotify' 'knotifications')
+source=('git+https://github.com/codestation/qcma.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd qcma
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build-qcma
+ mkdir -p build-qcma-kdenotifier
+}
+
+build() {
+ pushd build-qcma &> /dev/null
+ lrelease-qt5 ../qcma/resources/translations/*.ts
+ qmake-qt5 ../qcma/qcma.pro PREFIX=/usr
+ make
+ popd &> /dev/null
+ pushd build-qcma-kdenotifier &> /dev/null
+ lrelease-qt5 ../qcma/resources/translations/*.ts
+ qmake-qt5 ../qcma/qcma_kdenotifier.pro PREFIX="/usr" CONFIG+=ENABLE_KNOTIFICATIONS
+ popd &> /dev/null
+}
+
+package_qcma-git() {
+ pkgdesc="Content Manager Assistant for the PS Vita. (GIT Version)"
+ depends=('ffmpeg' 'qt5-base' 'libnotify' 'vitamtpmod' 'hicolor-icon-theme')
+ conflicts=('qcma')
+ provides=('qcma')
+ install=qcma-git.install
+
+ make -C build-qcma INSTALL_ROOT="${pkgdir}" install
+}
+
+package_qcma-kdenotifier-git() {
+ pkgdesc="Content Manager Assistant for the PS Vita. (KDE notifier) (GIT Version)"
+ depends=('qcma-git' 'knotifications')
+ conflicts=('qcma-kdenotifier')
+ provides=('qcma-kdenotifier')
+
+ make -C build-qcma-kdenotifier INSTALL_ROOT="${pkgdir}" install
+} \ No newline at end of file
diff --git a/qcma-git.install b/qcma-git.install
new file mode 100644
index 000000000000..8952ea4b2a22
--- /dev/null
+++ b/qcma-git.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+
+post_remove() {
+ post_install
+}