summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-11-26 19:53:35 +0100
committerGustavo Alvarez2016-11-26 19:53:35 +0100
commitdba2913b41b5499ffc6c92982fd9533f971ee2e1 (patch)
tree11aa296eaa8f4b229d887943337084be37bc7239
parent000a46cc03af0f538b146ba5ebf6a7cf3c9e739e (diff)
downloadaur-dba2913b41b5499ffc6c92982fd9533f971ee2e1.tar.gz
Remove appindicator and kdenotifier plugins (by upstream)
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD62
2 files changed, 21 insertions, 76 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44bf68fa5b08..173c493b4ad9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Apr 30 13:58:26 UTC 2016
+# Sat Nov 26 18:52:51 UTC 2016
pkgbase = qcma-git
pkgdesc = Content Manager Assistant for the PS Vita. (GIT version)
- pkgver = v0.3.12.0.g498ebb1
+ pkgver = v0.4.1.0.g6044fbf
pkgrel = 1
url = https://github.com/codestation/qcma
arch = i686
@@ -10,36 +10,15 @@ pkgbase = qcma-git
license = GPL
makedepends = git
makedepends = qt5-tools
- makedepends = qt5-base
- makedepends = libvitamtp
- makedepends = ffmpeg
- makedepends = libnotify
- makedepends = knotifications
- makedepends = libappindicator-gtk2
- source = git+https://github.com/codestation/qcma.git
- sha1sums = SKIP
-
-pkgname = qcma-git
- pkgdesc = Content Manager Assistant for the PS Vita. (GIT Version)
depends = ffmpeg
depends = qt5-base
depends = libnotify
depends = libvitamtp
depends = hicolor-icon-theme
- provides = qcma
- conflicts = qcma
-
-pkgname = qcma-kdenotifier-git
- pkgdesc = Content Manager Assistant for the PS Vita. (KDE notifier) (GIT Version)
- depends = qcma-git
- depends = knotifications
- provides = qcma-kdenotifier
- conflicts = qcma-kdenotifier
+ conflicts = qcma-appindicator-git
+ conflicts = qcma-kdenotifier-git
+ source = git+https://github.com/codestation/qcma.git
+ sha1sums = SKIP
-pkgname = qcma-appindicator-git
- pkgdesc = Content Manager Assistant for the PS Vita. (appindicator) (GIT Version)
- depends = qcma-git
- depends = libappindicator-gtk2
- provides = qcma-appindicator
- conflicts = qcma-appindicator
+pkgname = qcma-git
diff --git a/PKGBUILD b/PKGBUILD
index a9a0f132153c..61e944fb08cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
# Contributor: codestation <codestation404@gmail.com>
-pkgbase=qcma-git
-pkgname=('qcma-git'
- 'qcma-kdenotifier-git'
- 'qcma-appindicator-git')
-pkgver=v0.3.12.0.g498ebb1
+pkgname=qcma-git
+pkgver=v0.4.1.0.g6044fbf
pkgrel=1
pkgdesc="Content Manager Assistant for the PS Vita. (GIT version)"
arch=('i686' 'x86_64')
url='https://github.com/codestation/qcma'
license=('GPL')
+depends=('ffmpeg'
+ 'qt5-base'
+ 'libnotify'
+ 'libvitamtp'
+ 'hicolor-icon-theme'
+ )
makedepends=('git'
'qt5-tools'
- 'qt5-base'
- 'libvitamtp'
- 'ffmpeg'
- 'libnotify'
- 'knotifications'
- 'libappindicator-gtk2'
)
+conflicts=('qcma-appindicator-git'
+ 'qcma-kdenotifier-git'
+ )
source=('git+https://github.com/codestation/qcma.git')
sha1sums=('SKIP')
@@ -35,44 +35,10 @@ prepare() {
build() {
cd build
lrelease-qt5 "${srcdir}/qcma/common/resources/translations/"*.ts
- qmake-qt5 "${srcdir}/qcma/qcma.pro" PREFIX=/usr CONFIG+="ENABLE_KDENOTIFIER ENABLE_KNOTIFICATIONS ENABLE_APPINDICATOR"
+ qmake-qt5 "${srcdir}/qcma/qcma.pro" PREFIX=/usr
make
}
-package_qcma-git() {
- pkgdesc="Content Manager Assistant for the PS Vita. (GIT Version)"
- depends=('ffmpeg'
- 'qt5-base'
- 'libnotify'
- 'libvitamtp'
- 'hicolor-icon-theme'
- )
- conflicts=('qcma')
- provides=('qcma')
-
- make -C build/common INSTALL_ROOT="${pkgdir}" install
- make -C build/cli INSTALL_ROOT="${pkgdir}" install
- make -C build/gui INSTALL_ROOT="${pkgdir}" install
-}
-
-package_qcma-kdenotifier-git() {
- pkgdesc="Content Manager Assistant for the PS Vita. (KDE notifier) (GIT Version)"
- depends=('qcma-git'
- 'knotifications'
- )
- conflicts=('qcma-kdenotifier')
- provides=('qcma-kdenotifier')
-
- make -C build/kdenotifier INSTALL_ROOT="${pkgdir}" install
-}
-
-package_qcma-appindicator-git() {
- pkgdesc="Content Manager Assistant for the PS Vita. (appindicator) (GIT Version)"
- depends=('qcma-git'
- 'libappindicator-gtk2'
- )
- conflicts=('qcma-appindicator')
- provides=('qcma-appindicator')
-
- make -C build/appindicator INSTALL_ROOT="${pkgdir}" install
+package() {
+ make -C build INSTALL_ROOT="${pkgdir}" install
}