summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072016-01-05 18:48:22 +0100
committersl1pkn072016-01-05 18:48:22 +0100
commita8393495bb808fb84e29127d6be2f4bb037a44f9 (patch)
tree20613e1efcbfc2a524c1bb298abe876ed8b32f2c
downloadaur-a8393495bb808fb84e29127d6be2f4bb037a44f9.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD49
-rw-r--r--qcomicbook-git.install11
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47b3bc61b407
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Tue Jan 5 17:48:22 UTC 2016
+pkgbase = qcomicbook-git
+ pkgdesc = QComicBook is a viewer for comic book archives. (GIT version)
+ pkgver = 0.8.2.85.g2b1748f
+ pkgrel = 1
+ url = http://qcomicbook.org
+ install = qcomicbook-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ depends = qt5-x11extras
+ depends = desktop-file-utils
+ depends = poppler-qt5
+ optdepends = unzip
+ optdepends = unace
+ optdepends = unrar
+ optdepends = p7zip
+ optdepends = tar
+ provides = qcomicbook
+ conflicts = qcomicbook
+ source = qcomicbook::git+https://github.com/stolowski/QComicBook.git
+ sha1sums = SKIP
+
+pkgname = qcomicbook-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..caeaf5cbbf71
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!qcomicbook-git.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf4f040f6bf1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=qcomicbook-git
+pkgver=0.8.2.85.g2b1748f
+pkgrel=1
+pkgdesc="QComicBook is a viewer for comic book archives. (GIT version)"
+arch=('i686' 'x86_64')
+url='http://qcomicbook.org'
+license=('GPL')
+depends=('qt5-x11extras'
+ 'desktop-file-utils'
+ 'poppler-qt5'
+ )
+optdepends=('unzip'
+ 'unace'
+ 'unrar'
+ 'p7zip'
+ 'tar'
+ )
+makedepends=('cmake'
+ 'git'
+ )
+provides=('qcomicbook')
+conflicts=('qcomicbook')
+source=('qcomicbook::git+https://github.com/stolowski/QComicBook.git')
+sha1sums=('SKIP')
+install=qcomicbook-git.install
+
+pkgver() {
+ cd qcomicbook
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../qcomicbook \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+} \ No newline at end of file
diff --git a/qcomicbook-git.install b/qcomicbook-git.install
new file mode 100644
index 000000000000..f8d47ca11489
--- /dev/null
+++ b/qcomicbook-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file