summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2015-06-03 19:59:53 +0200
committerHyacinthe Cartiaux2015-06-09 10:18:33 +0200
commit009ba9fa4d4dfb78b3532327cfef44b42dfd9dc1 (patch)
treea42aa6ca0aaf18b3b51338a7ed0f137edccd263f
downloadaur-009ba9fa4d4dfb78b3532327cfef44b42dfd9dc1.tar.gz
[qconf-git] Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD52
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85eeed1777b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = qconf-git
+ pkgdesc = Qt5 compatible qconf - Qt configuration tool
+ pkgver = 1.5_20150603
+ pkgrel = 1
+ url = https://github.com/psi-plus/qconf
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = qt4
+ provides = qconf
+ conflicts = qconf
+ source = git+https://github.com/psi-plus/qconf.git
+ md5sums = SKIP
+
+pkgname = qconf-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aaa877123d5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Hyacinthe Cartiaux
+pkgname=qconf-git
+pkgver=1.5_20150603
+pkgrel=1
+pkgdesc="Qt5 compatible qconf - Qt configuration tool"
+arch=('i686' 'x86_64')
+url="https://github.com/psi-plus/qconf"
+license=('GPL2')
+depends=('qt4')
+makedepends=('git')
+conflicts=(qconf)
+provides=(qconf)
+source=(git+https://github.com/psi-plus/qconf.git)
+md5sums=('SKIP')
+
+pkgver() {
+ echo 1.5_$(date +"%Y%m%d")
+}
+
+_gitroot=https://github.com/psi-plus/
+_gitname=qconf
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build/"
+
+ # BUILD HERE
+
+ ./configure --prefix=/usr
+ make
+
+}
+
+package() {
+ cd $srcdir/qconf-build
+
+ make INSTALL_ROOT="$pkgdir" install
+}
+