summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHannah Kiekens2021-06-18 15:33:59 +0200
committerHannah Kiekens2021-06-18 15:41:50 +0200
commitfc720f82b74bda7ab491d4b69647cf58e8612eef (patch)
treee1597c85a862932cd56417c25b2dec9b22a676e9
downloadaur-fc720f82b74bda7ab491d4b69647cf58e8612eef.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9ac2ad1ce32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = qcoro-git
+ pkgdesc = C++ Coroutine library for Qt
+ pkgver = r82.3147d44
+ pkgrel = 1
+ url = https://qcoro.dvratil.cz/
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ depends = qt5-base
+ provides = qcoro
+ conflicts = qcoro
+ source = git+https://github.com/danvratil/qcoro.git
+ sha256sums = SKIP
+
+pkgname = qcoro-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c1d9c035f36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Hannah Kiekens <hannahkiekens@gmail.com>
+
+pkgname=qcoro-git
+pkgver=r82.3147d44
+pkgrel=1
+pkgdesc='C++ Coroutine library for Qt'
+arch=(x86_64 armv6h armv7h aarch64)
+url="https://qcoro.dvratil.cz/"
+license=(MIT)
+depends=(qt5-base )
+makedepends=(git cmake)
+provides=(qcoro)
+conflicts=(qcoro)
+source=("git+https://github.com/danvratil/qcoro.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname%-git}"
+ cmake . \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib
+ make
+}
+
+package() {
+ cd "${pkgname%-git}"
+ make DESTDIR="$pkgdir" install
+}