summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2016-01-29 19:43:24 +0330
committerMohammadreza Abdollahzadeh2016-01-29 19:43:24 +0330
commit20c8fdadb78a254bf9b5109c6e24f72338ac6581 (patch)
tree14faeb2233572ee8194cfdd73bcedaccddb46952
parent2efaa72571ed507b38a39873ed22bcdc5dc9c45e (diff)
downloadaur-20c8fdadb78a254bf9b5109c6e24f72338ac6581.tar.gz
Update to version 1.3.2 and adding documentations and examples
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 20 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be1429f21d67..8303c7f05997 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Jan 29 16:11:12 UTC 2016
pkgbase = qcustomplot-qt5
pkgdesc = Plotting library for Qt5
- pkgver = 1.3.1
+ pkgver = 1.3.2
pkgrel = 1
url = http://www.qcustomplot.com
arch = x86_64
arch = i686
license = GPL
depends = qt5-base
- source = http://www.qcustomplot.com/release/1.3.1/QCustomPlot-sharedlib.tar.gz
- source = http://www.qcustomplot.com/release/1.3.1/QCustomPlot-source.tar.gz
- md5sums = 05c3c32a28116b63e09213c8ed2b7055
- md5sums = 4448e2e3efbe92ea226fc21a5a1bde55
+ source = http://www.qcustomplot.com/release/1.3.2/QCustomPlot.tar.gz
+ source = http://www.qcustomplot.com/release/1.3.2/QCustomPlot-sharedlib.tar.gz
+ md5sums = a86d447230f7a3966cfbd946f7a3d301
+ md5sums = 82955a71538b18c23a320047ac32eace
pkgname = qcustomplot-qt5
diff --git a/PKGBUILD b/PKGBUILD
index 337aded4e82a..c7888f640194 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
-# Maintainer: ant32 <antreimer@gmail.com>
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz@gmail.com>
pkgname=qcustomplot-qt5
-pkgver=1.3.1
+pkgver=1.3.2
pkgrel=1
pkgdesc="Plotting library for Qt5"
url="http://www.qcustomplot.com"
arch=('x86_64' 'i686')
license=('GPL')
depends=('qt5-base')
-source=("http://www.qcustomplot.com/release/${pkgver}/QCustomPlot-sharedlib.tar.gz"
- "http://www.qcustomplot.com/release/${pkgver}/QCustomPlot-source.tar.gz")
-md5sums=('05c3c32a28116b63e09213c8ed2b7055'
- '4448e2e3efbe92ea226fc21a5a1bde55')
+source=("http://www.qcustomplot.com/release/${pkgver}/QCustomPlot.tar.gz"
+ "http://www.qcustomplot.com/release/${pkgver}/QCustomPlot-sharedlib.tar.gz")
+md5sums=('a86d447230f7a3966cfbd946f7a3d301'
+ '82955a71538b18c23a320047ac32eace')
build() {
cd "${srcdir}"
# fix path to source files
- sed -i 's|../../qcustomplot|../../qcustomplot-source/qcustomplot|g' \
+ sed -i 's|../../qcustomplot|../../qcustomplot/qcustomplot|g' \
"${srcdir}/qcustomplot-sharedlib/sharedlib-compilation/sharedlib-compilation.pro"
qmake-qt5 "${srcdir}/qcustomplot-sharedlib/sharedlib-compilation/sharedlib-compilation.pro"
@@ -26,7 +26,10 @@ build() {
package() {
cd "${srcdir}"
- mkdir -p "${pkgdir}/usr/"{lib,include}
- cp -a libqcustomplot.so* "$pkgdir/usr/lib"
- cp -a qcustomplot-source/qcustomplot.h "${pkgdir}/usr/include"
+ mkdir -p "${pkgdir}/usr/"{lib,include,share/{qcustomplot,doc/{qt,qcustomplot}}}
+ cp -a libqcustomplot.so* "$pkgdir/usr/lib/"
+ cp -a qcustomplot/qcustomplot.h "${pkgdir}/usr/include/"
+ cp -a qcustomplot/examples "${pkgdir}/usr/share/qcustomplot/"
+ cp -a qcustomplot/documentation/html "${pkgdir}/usr/share/doc/qcustomplot/"
+ cp -a qcustomplot/documentation/qcustomplot.qch "${pkgdir}/usr/share/doc/qt/"
}