summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip A Reimer2015-06-12 22:09:51 -0600
committerPhilip A Reimer2015-06-12 22:09:51 -0600
commit2efaa72571ed507b38a39873ed22bcdc5dc9c45e (patch)
treef432692094096dbcad2de3ed36dd3d5e43fbc023
downloadaur-2efaa72571ed507b38a39873ed22bcdc5dc9c45e.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be1429f21d67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = qcustomplot-qt5
+ pkgdesc = Plotting library for Qt5
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://www.qcustomplot.com
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = qt5-base
+ source = http://www.qcustomplot.com/release/1.3.1/QCustomPlot-sharedlib.tar.gz
+ source = http://www.qcustomplot.com/release/1.3.1/QCustomPlot-source.tar.gz
+ md5sums = 05c3c32a28116b63e09213c8ed2b7055
+ md5sums = 4448e2e3efbe92ea226fc21a5a1bde55
+
+pkgname = qcustomplot-qt5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..337aded4e82a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: ant32 <antreimer@gmail.com>
+
+pkgname=qcustomplot-qt5
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Plotting library for Qt5"
+url="http://www.qcustomplot.com"
+arch=('x86_64' 'i686')
+license=('GPL')
+depends=('qt5-base')
+source=("http://www.qcustomplot.com/release/${pkgver}/QCustomPlot-sharedlib.tar.gz"
+ "http://www.qcustomplot.com/release/${pkgver}/QCustomPlot-source.tar.gz")
+md5sums=('05c3c32a28116b63e09213c8ed2b7055'
+ '4448e2e3efbe92ea226fc21a5a1bde55')
+
+build() {
+ cd "${srcdir}"
+
+ # fix path to source files
+ sed -i 's|../../qcustomplot|../../qcustomplot-source/qcustomplot|g' \
+ "${srcdir}/qcustomplot-sharedlib/sharedlib-compilation/sharedlib-compilation.pro"
+
+ qmake-qt5 "${srcdir}/qcustomplot-sharedlib/sharedlib-compilation/sharedlib-compilation.pro"
+ make release
+}
+
+package() {
+ cd "${srcdir}"
+ mkdir -p "${pkgdir}/usr/"{lib,include}
+ cp -a libqcustomplot.so* "$pkgdir/usr/lib"
+ cp -a qcustomplot-source/qcustomplot.h "${pkgdir}/usr/include"
+}