summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIcaro Perseo2016-10-10 11:13:49 -0500
committerIcaro Perseo2016-10-10 11:13:49 -0500
commit3b4d9ca727c100c4ced2dbeb0b084931952bd566 (patch)
tree200ec793cc975d4310f6c11dfd65826822ed9558
downloadaur-3b4d9ca727c100c4ced2dbeb0b084931952bd566.tar.gz
First commit.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD44
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ade8ec36f7b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = qdc
+ pkgdesc = Castilian dictionary written using Qt5
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/javierllorente/qdc/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = GPL3
+ depends = hicolor-icon-theme
+ depends = qt5-webkit
+ source = https://github.com/javierllorente/qdc/archive/v1.0.0/qdc-1.0.0.tar.gz
+ sha256sums = 2f34c176cba20fb9ce73310ad12e67c6f985766b2797aa38b56bf7089c51863b
+
+pkgname = qdc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecc8d1ce4b98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Icaro Perseo <icaroperseo[at]protonmail[dot]com>
+
+pkgname=qdc
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Castilian dictionary written using Qt5"
+arch=(i686 x86_64)
+url="https://github.com/javierllorente/qdc/"
+license=('GPL' 'GPL3')
+depends=('hicolor-icon-theme' 'qt5-webkit')
+source=("https://github.com/javierllorente/qdc/archive/v1.0.0/qdc-1.0.0.tar.gz")
+sha256sums=('2f34c176cba20fb9ce73310ad12e67c6f985766b2797aa38b56bf7089c51863b')
+
+build() {
+ cd $pkgname-$pkgver
+ qmake qdc.pro
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # Desktop file
+ install -Dm644 $pkgname.desktop \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ # Icon
+ install -Dm644 icons/$pkgname.png \
+ "$pkgdir/usr/share/icons/hicolor/128x128/apps/$pkgname.png"
+
+ # Migration bash script (migrate conf files from qRAE to qdc)
+ install -Dm644 scripts/migrate.sh \
+ "$pkgdir/usr/share/${pkgname}/autostart/migrate.sh"
+
+ # Licenses
+ install -Dm644 gpl-2.0.txt \
+ "${pkgdir}/usr/share/licenses/${pkgname}/gpl-2.0.txt"
+ install -Dm644 gpl-3.0.txt \
+ "${pkgdir}/usr/share/licenses/${pkgname}/gpl-3.0.txt"
+}
+
+# vim:set ts=2 sw=2 cc=80 et: