summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIván Ruvalcaba2017-04-24 13:09:22 -0500
committerIván Ruvalcaba2017-04-24 13:09:22 -0500
commit6b04c760622516f54aaf5b43b18d0be93217bc5f (patch)
tree459442fb2205610bf9195fb2f7a73cbb4716eb51
parent4da860220ece0e3c9f3a439a18609d1599d37959 (diff)
downloadaur-6b04c760622516f54aaf5b43b18d0be93217bc5f.tar.gz
Improve package
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb211a80e86b..86a117ce0e19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,35 +9,35 @@ conflicts=('qrae-git')
url="https://github.com/javierllorente/qdc/"
license=('GPL' 'GPL3')
depends=('hicolor-icon-theme' 'qt5-webkit')
-source=("https://github.com/javierllorente/qdc/archive/v1.0.0/qdc-1.0.0.tar.gz")
+source=("https://github.com/javierllorente/${pkgname}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('2f34c176cba20fb9ce73310ad12e67c6f985766b2797aa38b56bf7089c51863b')
build() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
qmake qdc.pro
make
}
package() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
make INSTALL_ROOT="${pkgdir}" install
# Desktop file
install -Dm644 qdc.desktop \
- "$pkgdir/usr/share/applications/qdc.desktop"
+ "${pkgdir}/usr/share/applications/qdc.desktop"
# Icon
install -Dm644 icons/qdc.png \
- "$pkgdir/usr/share/icons/hicolor/128x128/apps/qdc.png"
+ "${pkgdir}/usr/share/icons/hicolor/128x128/apps/qdc.png"
# Migration bash script (migrate conf files from qRAE to qdc)
install -Dm644 scripts/migrate.sh \
- "$pkgdir/usr/share/${pkgname}/autostart/migrate.sh"
+ "${pkgdir}/usr/share/${pkgname}/autostart/migrate.sh"
# Doc files
install -Dm644 ChangeLog \
- "$pkgdir/usr/share/doc/${pkgname}/ChangeLog"
+ "${pkgdir}/usr/share/doc/${pkgname}/ChangeLog"
# License
install -Dm644 COPYING \