summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkevku2018-12-05 19:52:03 +0200
committerkevku2018-12-05 19:52:03 +0200
commitea3f45ef2912744ad6edb23808cdabee40092890 (patch)
treebf66b53e11a1c297927757d9707d20337ed7063a
parent5983a2602a744a7892e7dc499aa9bbb29513d88c (diff)
downloadaur-ea3f45ef2912744ad6edb23808cdabee40092890.tar.gz
update 4.2.0.43
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6081db3c234..cbad2bfb33d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qdigidoc4
pkgdesc = DigiDoc4 Client is an application for digitally signing and encrypting documents; the software includes functionality to manage Estonian ID-card - change pin codes, update certificates etc.
- pkgver = 4.1.0.30
+ pkgver = 4.2.0.43
pkgrel = 1
url = http://www.id.ee/
arch = x86_64
@@ -13,13 +13,14 @@ pkgbase = qdigidoc4
depends = opensc>=0.18.0
depends = qt5-svg
depends = hicolor-icon-theme
+ depends = desktop-file-utils
optdepends = ccid: smart card support
provides = qdigidoc
provides = qesteidutil
conflicts = qdigidoc
conflicts = qesteidutil
- source = https://installer.id.ee/media/ubuntu/pool/main/q/qdigidoc4/qdigidoc4_4.1.0.30.orig.tar.xz
- sha256sums = fd66e309968fcf7a1ff4857f505c414fec0926afec9c5ec4fb0fdecdb41911e4
+ source = https://installer.id.ee/media/ubuntu/pool/main/q/qdigidoc4/qdigidoc4_4.2.0.43.orig.tar.xz
+ sha256sums = 1f2efa3d99e3f0da689e194161377306d7de2b25840b2398d7a4c67f4105ed2a
pkgname = qdigidoc4
diff --git a/PKGBUILD b/PKGBUILD
index 10bdbdb24d4..754237195a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: kevku <kevku@gmx.com>
pkgname=qdigidoc4
-pkgver=4.1.0.30
+pkgver=4.2.0.43
pkgrel=1
pkgdesc="DigiDoc4 Client is an application for digitally signing and encrypting documents; the software includes functionality to manage Estonian ID-card - change pin codes, update certificates etc."
arch=('x86_64' 'i686')
url="http://www.id.ee/"
license=('LGPL2.1')
-depends=('libdigidocpp>=3.13.6' 'opensc>=0.18.0' 'qt5-svg' 'hicolor-icon-theme')
+depends=('libdigidocpp>=3.13.6' 'opensc>=0.18.0' 'qt5-svg' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools' 'qt5-translations')
optdepends=('ccid: smart card support')
conflicts=('qdigidoc' 'qesteidutil')
provides=('qdigidoc' 'qesteidutil')
source=("https://installer.id.ee/media/ubuntu/pool/main/q/$pkgname/${pkgname}_$pkgver.orig.tar.xz")
-sha256sums=('fd66e309968fcf7a1ff4857f505c414fec0926afec9c5ec4fb0fdecdb41911e4')
+sha256sums=('1f2efa3d99e3f0da689e194161377306d7de2b25840b2398d7a4c67f4105ed2a')
prepare() {
[[ -d "$pkgname-build" ]] && rm -r "$pkgname-build"
mkdir "$pkgname-build"
- sed -i 's|#{ENV\["BUILD_NUMBER"\]}|30|g' cmake/modules/VersionInfo.cmake
+ sed -i 's|#{ENV\["BUILD_NUMBER"\]}|43|g' cmake/modules/VersionInfo.cmake
}
build() {