summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Doege2016-02-20 17:33:13 +0100
committerMartin Doege2016-02-20 17:33:13 +0100
commita587b76bde9c1ae2f48520a1f4c50f83a546454b (patch)
treead4d7f4c40fcf62a81c57c8145f61296d415b793
downloadaur-a587b76bde9c1ae2f48520a1f4c50f83a546454b.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..653c9d472c65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat Feb 20 16:30:22 UTC 2016
+pkgbase = qdirstat-git
+ pkgdesc = GUI disk usage utility (successor to kdirstat)
+ pkgver = 20160220.0e70c88
+ pkgrel = 1
+ url = https://github.com/shundhammer/qdirstat
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = qt5-base
+ source = git://github.com/shundhammer/qdirstat.git
+ md5sums = SKIP
+
+pkgname = qdirstat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8a49509561e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Martin C. Doege <mdoege at compuserve dot com>
+
+pkgname=qdirstat-git
+_pkgname=qdirstat
+pkgver=20160220.0e70c88
+pkgrel=1
+pkgdesc="GUI disk usage utility (successor to kdirstat)"
+arch=('i686' 'x86_64')
+url="https://github.com/shundhammer/qdirstat"
+license=('GPL2')
+depends=('qt5-base')
+makedepends=('git')
+source=("git://github.com/shundhammer/qdirstat.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+build () {
+ cd "$srcdir/${_pkgname}"
+ qmake
+ make
+}
+
+package () {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT="${pkgdir}" install
+}