summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel2020-05-22 23:02:22 +0200
committerDaniel2020-05-22 23:02:22 +0200
commite753f89c974dbe81d94c6ef92b5e715650157735 (patch)
tree8dad6bb07a57699713ffe3090e660b9cbf6a96a1
parente536d5f64c0bf1fa228ff0b204bc4f7baca00452 (diff)
downloadaur-e753f89c974dbe81d94c6ef92b5e715650157735.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
-rwxr-xr-xdisk-remover10
-rw-r--r--disk-remover.desktop17
4 files changed, 26 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1956f520713b..4b5b2e240e45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
-pkgbase = disk-remover
- pkgdesc = A little script that helps you to remove disks
- pkgver = 1
+pkgbase = qdl-git
+ pkgdesc = This tool communicates with USB devices of id 05c6:9008 to upload a flash loader and use this to flash images
+ pkgver = 760b3dffb03d2b7dfb82c6eac652a092f51c572d
pkgrel = 0
- url = https://github.com/dus2002/Disk-Remover
+ url = https://git.linaro.org/landing-teams/working/qualcomm/qdl.git
arch = any
license = GPL
- source = disk-remover.desktop
- source = disk-remover
- sha512sums = SKIP
+ depends = libxml2
+ source = git://git.linaro.org/landing-teams/working/qualcomm/qdl.git
sha512sums = SKIP
-pkgname = disk-remover
+pkgname = qdl-git
diff --git a/PKGBUILD b/PKGBUILD
index d59548299d73..63b543d3a7ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,27 @@
# Mantainer: Daniel Urdiales <daniurdi46@gmail.com>
-pkgname=disk-remover
-pkgver=1
+pkgname=qdl-git
+pkgver=760b3dffb03d2b7dfb82c6eac652a092f51c572d
pkgrel=0
-pkgdesc="A little script that helps you to remove disks"
+pkgdesc="This tool communicates with USB devices of id 05c6:9008 to upload a flash loader and use this to flash images"
arch=(any)
-url="https://github.com/dus2002/Disk-Remover"
+url="https://git.linaro.org/landing-teams/working/qualcomm/qdl.git"
license=(GPL)
-source=("$pkgname.desktop" "$pkgname")
-sha512sums=('SKIP' 'SKIP')
+depends=('libxml2')
+source=("git://git.linaro.org/landing-teams/working/qualcomm/qdl.git")
+sha512sums=('SKIP')
+
+prepare() {
+ cd qdl
+ git reset --hard $pkgver
+}
+
+build() {
+ cd qdl
+ make
+}
package() {
- mkdir -p ${pkgdir}/usr/share/applications
- cp $pkgname.desktop ${pkgdir}/usr/share/applications
- cp $pkgname $pkgdir/usr/bin
+ cd qdl
+ make DESTDIR="$pkgdir" install
}
diff --git a/disk-remover b/disk-remover
deleted file mode 100755
index 56514a7ab4fe..000000000000
--- a/disk-remover
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/bash
-
-echo Disk Remover
-echo
-lsblk
-echo
-echo
-read -p "Type device name (sdd or something like that), and press enter: "
-echo 1 > /sys/block/$REPLY/device/delete
-exit \ No newline at end of file
diff --git a/disk-remover.desktop b/disk-remover.desktop
deleted file mode 100644
index aed5c1315ee3..000000000000
--- a/disk-remover.desktop
+++ /dev/null
@@ -1,17 +0,0 @@
-[Desktop Entry]
-Comment=Disk-Remover
-Exec=disk-remover
-GenericName=
-Icon=gnome-disks
-MimeType=
-Name=Disk-Remover
-NoDisplay=false
-Path=
-StartupNotify=true
-Terminal=true
-TerminalOptions=
-Type=Application
-X-DBUS-ServiceName=
-X-DBUS-StartupType=none
-X-KDE-SubstituteUID=true
-X-KDE-Username=root