summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2022-03-05 19:40:35 -0500
committerSolomon Choina2022-03-05 19:40:35 -0500
commit0c4acccb984b3276b8f0d1401c1a86e3cb0dd225 (patch)
tree24b6622c533c1f4691e0549b40fc3194a72f4b7a
downloadaur-0c4acccb984b3276b8f0d1401c1a86e3cb0dd225.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41047a5d194a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = qdocumentview-git
+ pkgdesc = QDocumentView is a widget to render multi-page documents
+ pkgver = r7.d58dd20
+ pkgrel = 1
+ url = https://gitlab.com/marcusbritanicus/qdocumentview
+ arch = x86_64
+ license = GPL
+ makedepends = meson
+ makedepends = git
+ makedepends = poppler-qt5
+ depends = qt5-base
+ depends = djvulibre
+ depends = poppler-qt5
+ source = git+https://gitlab.com/marcusbritanicus/qdocumentview
+ sha256sums = SKIP
+
+pkgname = qdocumentview-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ba0a0b3b4b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: solaraquarion <shlomochoina@gmail.com>
+pkgname=qdocumentview-git
+pkgver=r7.d58dd20
+pkgrel=1
+pkgdesc="QDocumentView is a widget to render multi-page documents"
+arch=('x86_64')
+url="https://gitlab.com/marcusbritanicus/qdocumentview"
+license=('GPL')
+depends=('qt5-base' 'djvulibre' 'poppler-qt5')
+makedepends=('meson' 'git' 'poppler-qt5')
+provides=()
+conflicts=()
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/qdocumentview"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ arch-meson qdocumentview build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir/" ninja -C build install
+}
+