summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2021-09-18 16:14:33 +0200
committerMartin T. H. Sandsmark2021-09-18 16:14:33 +0200
commit5489e3d5ef6cfdac0cf2a8ae24c8ffafc353a4a0 (patch)
tree3ba8c8704f719c872024f8b16aad62d97093fa49
parentbca080975f2618701b67662a28923d642f967a55 (diff)
downloadaur-5489e3d5ef6cfdac0cf2a8ae24c8ffafc353a4a0.tar.gz
Add optdepends
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 25 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a17de178655f..ad7aa445bfd0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,19 @@ pkgbase = qeh-git
arch = i686
arch = x86_64
license = GPL
+ makedepends = cmake
+ makedepends = git
depends = qt5-base
+ depends = qt5-x11extras
+ optdepends = kimageformats: Support for Windows cursors, AVIF, EPS, OpenEXR, Radiance HDR, HEIF, Krita, OpenRaster, Gimp, pic, Photoshop, SunOS raster, SGI RGB, Targa
+ optdepends = qt5-imageformats: Support for WebP, JPEG 2000, Targa, TIFF, Wireless Bitmap, MNG, DirectX textures, Apple icons
+ optdepends = qvtf: Support for Valve Texture Files
+ optdepends = qt5-jpegxl-image-plugin: Support for JPEG XL
+ optdepends = qt5-apng-plugin: Support for Animated PNG
+ optdepends = qt-avif-image-plugin: Alternative to kimageformats for AVIF support
+ optdepends = qt5-pbfimageplugin: Support for Mapbox vector tiles
+ optdepends = extra-imageformats-qt: Support for BPG, FUIF and PGF
+ optdepends = qtraw: Support for RAW files via libraw
provides = qeh
conflicts = qeh
source = git://github.com/sandsmark/qeh.git
diff --git a/PKGBUILD b/PKGBUILD
index b64c0502adb9..5357de856c49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,10 +7,22 @@ pkgdesc='Very simple and fast image viewer'
arch=('i686' 'x86_64')
url='https://github.com/sandsmark/qeh'
license=('GPL')
-depends=('qt5-base')
+depends=('qt5-base' 'qt5-x11extras')
+makedepends=('cmake' 'git')
conflicts=(qeh)
provides=(qeh)
source=('git://github.com/sandsmark/qeh.git')
+optdepends=(
+ 'kimageformats: Support for Windows cursors, AVIF, EPS, OpenEXR, Radiance HDR, HEIF, Krita, OpenRaster, Gimp, pic, Photoshop, SunOS raster, SGI RGB, Targa'
+ 'qt5-imageformats: Support for WebP, JPEG 2000, Targa, TIFF, Wireless Bitmap, MNG, DirectX textures, Apple icons'
+ 'qvtf: Support for Valve Texture Files'
+ 'qt5-jpegxl-image-plugin: Support for JPEG XL'
+ 'qt5-apng-plugin: Support for Animated PNG'
+ 'qt-avif-image-plugin: Alternative to kimageformats for AVIF support'
+ 'qt5-pbfimageplugin: Support for Mapbox vector tiles'
+ 'extra-imageformats-qt: Support for BPG, FUIF and PGF'
+ 'qtraw: Support for RAW files via libraw'
+ )
md5sums=('SKIP')
pkgver() {