summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2020-12-18 13:45:36 +0100
committerGianluca Boiano2020-12-18 13:45:36 +0100
commite06de9b96acdf50cad679b8282552944e41b3602 (patch)
treeb1127e186ebe1a8b86742a22725a8b30de3f9491
parent92868eb96e4cd18761895ff71aae48eb98f8bdb9 (diff)
downloadaur-e06de9b96acdf50cad679b8282552944e41b3602.tar.gz
qemu-arm-static: 5.2.0r1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 422a2812a67c..adc2c17d89bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = qemu-arm-static
pkgdesc = Statically linked qemu-arm, qemu-armeb and qemu-aarch64 executables from Alpine
- pkgver = 5.1.0r1
+ pkgver = 5.2.0r1
pkgrel = 1
url = https://alpinelinux.org/
install = qemu-arm-static.install
arch = x86_64
license = GPL2
- source = https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-aarch64-5.1.0-r1.apk
- source = https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-arm-5.1.0-r1.apk
- source = https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-armeb-5.1.0-r1.apk
+ source = https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-aarch64-5.2.0-r1.apk
+ source = https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-arm-5.2.0-r1.apk
+ source = https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-armeb-5.2.0-r1.apk
source = aarch64.binfmt
source = arm.binfmt
source = armeb.binfmt
- md5sums = ea656213fbe750169349b462a91b3e56
- md5sums = 81f38cb574b374310906904b413f81d3
- md5sums = b660cfbfc76a24b51a849f6124556827
+ md5sums = 4259c81a24e40f22b18525bd910e75c8
+ md5sums = 0af49ee74e68632de2770abc9e588d42
+ md5sums = 0af01ee94bf542ad3be52d0ef0d92865
md5sums = 11c56ac5b0463055b7e3bc1216fe639e
md5sums = 990e3e260665c1da56b5b1c71f480664
md5sums = 89569b9c545af650dfeab24d4f8bb677
diff --git a/PKGBUILD b/PKGBUILD
index a7a01f956740..bffd2ec6b777 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
pkgname=qemu-arm-static
-pkgver=5.1.0r1
+pkgver=5.2.0r1
_pkgver=${pkgver/r/-r}
pkgrel=1
pkgdesc='Statically linked qemu-arm, qemu-armeb and qemu-aarch64 executables from Alpine'
@@ -11,21 +11,21 @@ url='https://alpinelinux.org/'
license=(GPL2)
install=$pkgname.install
source=("https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-aarch64-$_pkgver.apk"
- "https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-arm-$_pkgver.apk"
- "https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-armeb-$_pkgver.apk"
- aarch64.binfmt arm.binfmt armeb.binfmt
+ "https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-arm-$_pkgver.apk"
+ "https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-armeb-$_pkgver.apk"
+ aarch64.binfmt arm.binfmt armeb.binfmt
)
package() {
- for arch in aarch64 arm armeb; do
- install -Dm755 usr/bin/qemu-"$arch" "$pkgdir/usr/bin/qemu-${arch}-static"
- install -Dm644 "${arch}".binfmt "$pkgdir/usr/lib/binfmt.d/${arch}.conf"
- done
+ for arch in aarch64 arm armeb; do
+ install -Dm755 usr/bin/qemu-"$arch" "$pkgdir/usr/bin/qemu-${arch}-static"
+ install -Dm644 "${arch}".binfmt "$pkgdir/usr/lib/binfmt.d/${arch}.conf"
+ done
}
-md5sums=('ea656213fbe750169349b462a91b3e56'
- '81f38cb574b374310906904b413f81d3'
- 'b660cfbfc76a24b51a849f6124556827'
- '11c56ac5b0463055b7e3bc1216fe639e'
- '990e3e260665c1da56b5b1c71f480664'
- '89569b9c545af650dfeab24d4f8bb677')
+md5sums=('4259c81a24e40f22b18525bd910e75c8'
+ '0af49ee74e68632de2770abc9e588d42'
+ '0af01ee94bf542ad3be52d0ef0d92865'
+ '11c56ac5b0463055b7e3bc1216fe639e'
+ '990e3e260665c1da56b5b1c71f480664'
+ '89569b9c545af650dfeab24d4f8bb677')